Bug 830797 - missing -lqpidtypes for LDFLAGS in /usr/share/qpidc/examples/messaging/Makefile
missing -lqpidtypes for LDFLAGS in /usr/share/qpidc/examples/messaging/Makefile
Status: CLOSED DUPLICATE of bug 802791
Product: Fedora
Classification: Fedora
Component: qpid-cpp (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Darryl L. Pierce
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-11 08:45 EDT by Gilles J. Seguin
Modified: 2015-06-21 20:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-12 15:55:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gilles J. Seguin 2012-06-11 08:45:44 EDT
Description of problem:
summary describes basic problem.

Version-Release number of selected component (if applicable):
qpid-cpp-client-devel-0.14-1.fc17.2.x86_64

How reproducible:
always

Steps to Reproduce:
1- copy files to $HOME/qpid/examples
   from /usr/share/qpidc/examples/messaging
2- cd $HOME/qpid/examples
3- make map_receiver
  
Actual results:
- /usr/bin/ld: /usr/lib/gcc/x86_64-redhat-linux/4.7.0/../../../../lib64 \
 /libqpidmessaging.so: undefined reference to symbol 'something'
- /usr/bin/ld: note: 'something'  is defined in DSO /lib64/libqpidtypes.so.1 so \
  try adding it to the linker command line
- /lib64/libqpidtypes.so.1: could not read symbols: Invalid operation

Expected results:
/usr/share/qpidc/examples/messaging/Makefile needs an additional dependency
line
-LDFLAGS==-lqpidmessaging
+LDFLAGS==-lqpidmessaging -lqpidtypes

Additional info:
Comment 1 Darryl L. Pierce 2012-10-12 15:55:22 EDT

*** This bug has been marked as a duplicate of bug 802791 ***

Note You need to log in before you can comment on or make changes to this bug.