Bug 80286 - Internet Connection Wizard crashes every time
Summary: Internet Connection Wizard crashes every time
Status: CLOSED DUPLICATE of bug 76446
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network   
(Show other bugs)
Version: 7.3
Hardware: athlon
OS: Linux
medium
high
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-24 03:08 UTC by Andrew Kerr
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bug report (2.10 KB, text/plain)
2002-12-24 03:15 UTC, Andrew Kerr
no flags Details

Description Andrew Kerr 2002-12-24 03:08:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
I have a copy of 7.3 (Valhalla) that was installed on a new computer as part of 
a dual boot system (Linux/WinXP). I have no installation disks or install files 
that I know of.

My network card appears to be working fine but I can't connect to the internet.

I've tried running the internet configuration wizard but it crashes. It 
recommended I submit a bug report.

I'm sending this through WinXP.

I will attach the logfile.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Enter Konsole window.
2.Type "internet-druid".
3.Provide root password.
    

Actual Results:  Error. "Traceback (innermost last)....."

Expected Results:  Some sort of internet connection wizard.

Additional info:

I have a Realtek network card that appears to be configured properly.

Comment 1 Andrew Kerr 2002-12-24 03:15:03 UTC
Created attachment 88873 [details]
Bug report

Comment 2 Rudy 2002-12-28 02:46:16 UTC
Please visit http://bugzilla.redhat.com/bugzilla/ !
File a bug against component redhat-config-network. Thank you!

Traceback (innermost last):
  File "/usr/sbin/internet-druid", line 1400, in ?
    window = mainDialog('druid')
  File "/usr/sbin/internet-druid", line 238, in __init__
    if modus == 'druid': self.on_deviceAddButton_clicked(None)
  File "/usr/sbin/internet-druid", line 473, in on_deviceAddButton_clicked
    interface = NewInterfaceDialog()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/NewInterfaceDialog.py",
line 82, in __init__
    iface = iface_creator (self.toplevel, do_save = None, druid = self.druid)
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetInterface.py",
line 101, in __init__
    self.hwDruid = ethernetHardware(self.toplevel)
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetHardwareDruid.py",
line 64, in __init__
    self.setup()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetHardwareDruid.py",
line 118, in setup
    list.append(modInfo[i]['description'])
KeyError: description


Comment 3 Harald Hoyer 2003-01-09 13:27:50 UTC

*** This bug has been marked as a duplicate of 76446 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:50:31 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.