Bug 80294 - (phoebeataraid) GUI installer says no drives found for installation
GUI installer says no drives found for installation
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
: 80392 (view as bug list)
Depends On:
Blocks: 79578
  Show dependency treegraph
Reported: 2002-12-23 23:57 EST by Nathan G. Grennan
Modified: 2007-04-18 12:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-02-13 17:51:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
lspci output (11.57 KB, text/plain)
2002-12-24 00:50 EST, Nathan G. Grennan
no flags Details
more lspci output (10.98 KB, text/plain)
2002-12-24 16:09 EST, Pekka Pietikäinen
no flags Details
lspci -v and lspci -nv from my home system (6.91 KB, text/plain)
2003-01-04 12:46 EST, Chris Kloiber
no flags Details

  None (edit)
Description Nathan G. Grennan 2002-12-23 23:57:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021216

Description of problem:
I booted off cd. Ran through the dialogs. Selected Custom install, Selected
Partition with Disk Druid, Clicked Next and it says no drives found for
installation or something like that. But the kernel saw them on boot. I tried
all the kernel options on boot I could think of and nothing helped. The drive is
on a Promise ATA133 RAID controller that works fine with 8.0. I currently have
8.0 on it and I am trying to fresh install 8.0.92. I tried autopartition and it
said the same thing.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot off cd
2. Run through dialogs
3. Select Custom Install
4. Select Partition with Disk Druid


Actual Results:  no drives found for installation

Expected Results:  Installer to let me partition

Additional info:
Comment 1 Warren Togami 2002-12-24 00:36:28 EST
What motherboard is this?

Are you using the Promise controller in RAID or non-RAID mode?

Can you type the following:
lspci -vv > system.txt
lspci -vn >> system.txt

Please attach system.txt here.
Comment 2 Nathan G. Grennan 2002-12-24 00:50:09 EST
Created attachment 88877 [details]
lspci output
Comment 3 Nathan G. Grennan 2002-12-24 00:50:52 EST
MSI KT3 Ultra2(VIA KT333 chipset)
Promise 20276 On-Board

It runs in RAID mode all the time since the jumper is missing. I am able to work
around the RAID mode by setting up each drive as it's own striped array. I would
probably have to solder the board to short the pads to get NON-RAID mode. It
works fine with all the other kernels I have tried. Including 2.4.18, 2.4.19,
2.4.20, and 2.5.50. I have three drives. The boot drive is a IBM 60gb. The other
two drives are a Maxtor 40gb and a WD 20gb. The Maxtor and WD are raw(as in no
partitions) LVM drives. I have had issues with the raw LVM drives with previous
installers, but I have tried disconnecting them and it had no effect. The main
drive is 4.5gb /, 50gb LVM(part of the array with the other drives), and 4gb /usr.
Comment 4 Jeffrey Clemmons 2002-12-24 01:08:33 EST
I have this problem also.  I thought it might be related to the RAID on my
motherboard (Also a Promise, FastTrak 100 Lite on a ECS K7VTA3 mobo).  Tried
switching the drives to my standard IDE channel and it doesn't change a thing, I
still get a "No Drives Found" error.  Maybe the presence of the RAID itself is
causing the problem?
Comment 5 Pekka Pietikäinen 2002-12-24 16:08:06 EST
Same thing happens on a Asus A7V8X (drives connected to onboard IDE controller,
no raid or anything). Also it doesn't find any existing RH installations it
could upgrade (although there should be one). The drive I tried to install
to is a 120G WD SE. 

lspci output attached
Comment 6 Pekka Pietikäinen 2002-12-24 16:09:34 EST
Created attachment 88900 [details]
more lspci output
Comment 7 Pekka Pietikäinen 2002-12-24 18:26:49 EST
The problem seems to lie in the promise raid code in anaconda (isys/pdc.c)
The code ignores the drive even if you don't use raid if the drive has been in a pdc
raid group, since the drive contains a valid promise raid superblock.
Comment 8 Nathan G. Grennan 2002-12-24 18:31:37 EST
I suspected as much. So I wonder when this brillant change was added and why.
Comment 9 Jeffrey Clemmons 2002-12-24 21:37:37 EST
Would this affect other drive channels though?  On my system I can't get it to work 
even if I move my drives to a standard IDE channel. 
Comment 10 Nathan G. Grennan 2002-12-24 21:43:22 EST
As mentioned above it sees the promise raid data marker that says it is part of
an array, so it ignores it. So even on another controller it sees the marker and
ignores it. For now to get it to work I think you would have to figure out how
to remove the marker and then put it on a regular controller, or switch the
promise controller to non-raid mode if you can and remove the marker. 
Comment 11 Nathan G. Grennan 2002-12-24 22:44:04 EST
I did more testing and it isn't just the Promise controller and/or Promise RAID

I was going to test a fresh from the manufacture after RMA 20gb Maxtor to see if
I could put data on it, make it an array, remove the array(the idea being remove
the marker), and see if the data was still intact.

In the process I decided to test to see if I could get Phoebe to see this drive
in the installer to test the marker theory. I connected it as Secondary Slave on
the VIA controller at first. Same error about no drive to partition/install on.
So then I switched it to Secondary Master, same thing. So then I switched it to
Primary Master, same thing. So then I disabled the Promise controller in the
bios, same thing. Tried initilizing it with linux rescue and then trying the
installer, same thing. Tried making a linux partition and making it active, same
thing. The whole time the kernel saw it as hda.

In the middle of this as the installer was crashing/rebooting I was able to use
the keyboard and switch virtual terminals. I saw it was having trouble loading
the paralell port driver. So I tried enabling it in the bios to see if it would
make the installer act better. It made no difference.

While in rescue mode I tried to fdisk /dev/hda, didn't work. Tried to use mknod
 to make /dev/hda, didn't work. Finally found the device file premade in /tmp
and was able to do what I mentioned above.

So it seems to be a general issue with this motherboard and/or chipset, since I
have all the same issues with a virgin hard drive on the VIA ide controllers.
Comment 12 Nathan G. Grennan 2002-12-24 22:51:17 EST
To clarify a few things. When it was the Secondary Slave and Master it was seen
as hdc and hdd. I meant to say while it was Primary Master and I tried various
things it was seen by the kernel as hda. As for the parallel port, enabling it
did make the driver load properly, but it didn't make a difference with the hard
drive problem.
Comment 13 Nathan G. Grennan 2002-12-24 23:27:15 EST
I just tried the same disc1 on my second computer(ABIT KT7A-RAID, KT133A,
Highpoint 370 RAID contoller). The first difference I noticed was a pretty
graphic over the boot: prompt. On my main computer it is just green text. I have
seen both ways before on different computers. Both the graphical installer and
text installer seem to work. I didn't get the no drive to install to error
message in the GUI. I didn't complete the install, because my second computer is
my MythTV computer and I don't want to mess with it.
Comment 14 Nathan G. Grennan 2002-12-25 01:36:28 EST
After figuring out how to get mknod to work(#80372) and how to use the
keyboard(#80293). I made sure that the device files hda, hdc, hde, hde1, hde2,
hde3, hdg, and hdh were in /dev and /tmp. Then I was able to use vgscan and
vgchange -a y to activate my lvm volume group. Didn't help with the detection od
drives for anaconda. I was also able to then mount /, /home, and /usr to
/mny/sysimage. Again it didn't help with the detection. So the kernel has
everything that is needed to mount the partitions, but anaconda isn't smart enough.
Comment 15 Nathan G. Grennan 2002-12-28 21:58:16 EST
Well, I finally got Phoebe installed after alot of pain. It does seem to have
been an issue with the Promise RAID array info. I found I could remove the array
info from a drive without affecting it's filesystems. So I removed the info,
moved the drives to my VIA controller, installed Phoebe, then moved them back to
the Promise controller. I did get an error about cylinders during the install,
but it said I could likely ignore it. I did and don't seem to have a problem. I
found cylinder info and linux is a complete mess. Each ide controller would do
the cynlinders/heads/sectors different and then linux would turn around and do
it differently than the controller. Why the brand new 20gb I mentioned before
didn't work I don't know. Maybe someone put it on a Promise RAID controller at
the manufacture.
Comment 16 Chris Kloiber 2003-01-04 12:40:20 EST
Can't be just a Promise issue. My system has a built in HPT370A and experienced
this issue. (lspci -v and lspci -nv will be attached) Lots of interrupt sharing
on IRQ 11, but I had hoped we were over that. No raid, software or firmware, is
in use. Here is the fdisk -l:

Disk /dev/hdg: 16 heads, 63 sectors, 77545 cylinders
Units = cylinders of 1008 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hdg1   *         1     73386  36986512+  83  Linux
/dev/hdg2         73387     77545   2096136   82  Linux swap

Disk /dev/hde: 255 heads, 63 sectors, 2482 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hde1   *         1      2481  19928601    c  Win95 FAT32 (LBA)

CDROM (CD-burner, DVD-reader) is on hda, which is on the VIA ide controller.
I tried CD, floppy, and isolinux copied to /boot install methods.
Comment 17 Chris Kloiber 2003-01-04 12:46:43 EST
Created attachment 89127 [details]
lspci -v and lspci -nv from my home system

If we don't have hardware that duplicates this in-house, I can bring this one
into  work for you to look at it Jeremy. (although it is my main system here at
Comment 18 Nathan G. Grennan 2003-01-20 08:57:13 EST
Just finished fresh installing Phoebe2. It has the same problem with not seeing
hard drives on my Promise RAID controller. At least this time it didn't require
me to remove the raid signature before I was able to use the drive on my normal
Comment 19 Jeremy Katz 2003-01-27 17:47:29 EST
Can you try downloading the update disk image from
http://people.redhat.com/~katzj/phoebe-pdcdetect.img and see if it works using
it?  (Information on using update disks is available from
Comment 20 Jeremy Katz 2003-02-13 17:51:01 EST
Closing as working in rawhide based on comments on other similar bugs
Comment 21 Jeremy Katz 2003-02-17 09:01:06 EST
*** Bug 80392 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.