This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 80310 - Cursor drawing problem
Cursor drawing problem
Status: CLOSED DUPLICATE of bug 75844
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2002-12-24 05:36 EST by Raphael Jacquot
Modified: 2008-01-17 12:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:50:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Raphael Jacquot 2002-12-24 05:36:31 EST
Description of problem:
On a Dell Inspiron 7500 (uses the ATI Mobility chipset), the nice,
semi-transparent mouse cursors are somewhat buggy, in that one or several
vertical lines are more transparent than the rest of the cursor all along the
cursor itself. It also shows on the shadow cast by said cursor.
Also, when the cursor is made to disappear in Gnome-terminal, there is a block
of uninitialized graphic (seems to be 64*64 or so) the first time the cursor
disappears.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. install on a Dell inspiron 7500 equiped with an ATI Mobility chipset
2. run any X app (even the login screen)
3. see the bug 
    
Actual results:
the cursors look wierd, with one or more vertical line more transparent than the
others

Expected results:
normal looking cursors ;-)

Additional info:
Comment 1 Warren Togami 2002-12-24 05:51:21 EST
I too noticed these few cursor glitches.  They aren't too bad, just a bit
aesthetically distracting because you are mentally focused on the pointer often.

The only thing I'd like to add is IMHO the drop shadow is about two pixels too
far from the cursor.  Does anyone else agree?  I realize this is nitpicking,
sorry. =)
Comment 2 Mike A. Harris 2002-12-25 14:22:32 EST
The white cursor with vertical lines problem is already reported in bugzilla
(by me actually, for tracking) and is now solved by removing the white
cursors completely (because nobody out there seems to want to fix them it
seems).

I guess XFree86.org is in need of volunteer artists.  I'm not sure if there
will be any shippable quality alpha cursors in time for 4.3.0.  If not, then
I won't ship any, however the feature will be enabled so that people can
create and install their own alpha cursors.

The glitch when changing cursors is known by Keith Packard upstream, and will
get fixed probably by him if it isn't already.

Warren) Yes, I agree, the drop shadow is too far away from the mouse cursor.
That's just another cosmetic issue though, something for an artist to fix I
guess.


*** This bug has been marked as a duplicate of 75844 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:50:32 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.