Bug 803182 - eekboard not showing inscript layout or others while press ctrl+space
eekboard not showing inscript layout or others while press ctrl+space
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eekboard (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daiki Ueno
Fedora Extras Quality Assurance
: i18n
: 803310 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-14 03:00 EDT by Sweta Kothari
Modified: 2015-04-21 00:35 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-19 06:07:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sweta Kothari 2012-03-14 03:00:25 EDT
Description of problem:
virtual keyboard is not visible with selected language keyboard layout, It is showing only english layout.

Version-Release number of selected component (if applicable):
eekboard-1.0.5-4.fc17.x86_64

How reproducible:


Steps to Reproduce:
1.run eekboard from terminal
2.Open gedit and change the layout with ctrl+space to check selected layout is working or not.
3.selected layout is not visible in eekboard, it is showing in english.
  
Actual results:
eekboard is showing in english while switching keyboard layout.

Expected results:
should be changed with selected language keyboard layout

Additional info:
Comment 1 Ani Peter 2012-03-14 03:44:08 EDT
Tried for Malayalam (ml_IN), tried eekboard using Malayalam Inscript with gedit. The eekboard display is in English, but it types respective Malayalam characters. ie, when I click on "key k", it displays the corresponing alphabet "ക" as per Inscript keyboard layout, but the eekboard display is in English.

Thanks
Ani
Comment 2 Manoj Kumar Giri 2012-03-14 04:32:17 EDT
No option available to switch to local interface to get local keyboard on screen. But the functionality is available while writing on an editor using "ctrl+space".
Comment 3 Shankar Prasad 2012-03-14 04:55:54 EDT
This issue exists for Kannada as well. Though I can can input Kannada characters, the virtual keyboard doesn't show Kannada letters on it.
Comment 4 Ani Peter 2012-03-14 05:35:08 EDT
Tested application again using the following steps:-
1. start eekboard
2. push left shift button (like ↑)
3. push a setup button at the bottom left corner
4. added "ml-inscript" to "Keyboard type:" before us.
5. Restarted the application.

Now the application worked correctly for Malayalam. But I guess the switching feature must be available without any tedious steps like above and restarting the application. Ideally, when we open eekboard to use for any editors, ctrl-space must enable the switching layout feature for the required locale. 

Thanks
Ani
Comment 5 Nilamdyuti 2012-03-14 10:41:13 EDT
Assamese inscript layout is displayed and can type with it. Pressing the 'keyboard icon' key switches the layout from English to Assamese inscript and vice-versa. Pressing ctrl + space switches input method of IBus but only to next in line after English, i,e. if after 'English' there is 'Assamese inscript' and 'Assamese phonetic' it switches only 'English' to 'Inscript' and vice-versa.
Comment 6 Daiki Ueno 2012-03-19 05:51:05 EDT
*** Bug 803310 has been marked as a duplicate of this bug. ***
Comment 7 Daiki Ueno 2012-03-19 06:07:10 EDT
I think this is not a bug (at least not a bug of eekboard), since eekboard itself never handles ctrl+space nor IBus engine change, while ibus-m17n has "Enable Virtual Keyboard" checkbox and if it is enabled (and if you launch eekboard from the IBus panel), it should work somehow as you expect.

Probably I should have updated the testcases earlier, but anyway, thanks for testing.  As a standalone application, Ani's comment #4 would be insightful and a good feature addition for F18.

Note You need to log in before you can comment on or make changes to this bug.