Bug 803374 - Need at-spi locators on dynamic text fields
Need at-spi locators on dynamic text fields
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Alex Wood
Entitlement Bugs
:
: 805594 (view as bug list)
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-03-14 11:23 EDT by J.C. Molet
Modified: 2012-06-20 09:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:07:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bundled products table (298.08 KB, image/png)
2012-03-14 11:24 EDT, J.C. Molet
no flags Details
my subscription details (341.29 KB, image/png)
2012-03-14 11:29 EDT, J.C. Molet
no flags Details
product details (484.15 KB, image/png)
2012-03-14 11:33 EDT, J.C. Molet
no flags Details
bundled prods fixed (344.09 KB, image/png)
2012-03-21 12:54 EDT, J.C. Molet
no flags Details
my subs mostly fixed (311.18 KB, image/png)
2012-03-21 13:08 EDT, J.C. Molet
no flags Details
my installed mostly fixed (351.41 KB, image/png)
2012-03-21 13:16 EDT, J.C. Molet
no flags Details

  None (edit)
Description J.C. Molet 2012-03-14 11:23:40 EDT
Description of problem:
The dynamically created fields in subscription manager need some tweaks to the at-spi locators.

Version-Release number of selected component (if applicable):
subscription-manager-gnome-0.99.9-1.git.12.2fc01bb.el6.x86_64

How reproducible:
always
  
Actual results:
The 'bundled products' table in the subscription details under 'all available subcriptions' needs a unique name in order to access it's members (see attachment).


Two more items to come in the following comments (one attachment limit)...
Comment 1 J.C. Molet 2012-03-14 11:24:22 EDT
Created attachment 570015 [details]
bundled products table
Comment 2 J.C. Molet 2012-03-14 11:29:50 EDT
Created attachment 570016 [details]
my subscription details

The text fields in the subscription details under 'my subscriptions"  all need to be named  '<name>-Text'.  They all follow this rule except for:

End Date
Start Date

Stacking ID  (currently has no name)

Bundled Products table  (currently has no name)
Comment 3 J.C. Molet 2012-03-14 11:33:33 EDT
Created attachment 570017 [details]
product details

The following text fields need to be renamed under the  "Product's Subscription Details" under the "My Installed Software" tab:

Subscription
Certificate Status
Product

These should generally follow the <name>-Text naming scheme that everything else has been using.
Comment 4 J.C. Molet 2012-03-14 11:53:05 EDT
To only further complicate the matter, all names must be unique between the three tabs.  Since these are simply panes with data in them and not tables, all these text fields have the same parent window:  "Subscription Manager".  When you call for the text fields it will search all three tabs and simply return whichever it finds first (usually by render order).

Currently these fields do not have unique names:

- The bundled products tables (currently unnamed - found in 'All Available Subscriptions and My Subscriptions)

- Subscription Text (found in all three tabs)

- Service Level Text (All Available Subscriptions, My Subscriptions) 

- Service Type Text (All Available Subscriptions, My Subscriptions)
Comment 5 Alex Wood 2012-03-16 14:35:50 EDT
Committed 495d07cf0352ab38a31c691782f89e8743a76026

Available in subscription-manager-0.99.11+
Comment 7 J.C. Molet 2012-03-21 12:54:57 EDT
Created attachment 571773 [details]
bundled prods fixed

tested in: subscription-manager-gnome-0.99.10-1.git.85.057ca98.el6.x86_64

comment 0 appears fixed; the table is now called "Bundled Products Table" and works via the api:

user> (tasks/ui getcellvalue "Subscription Manager" "Bundled Products Table" 0 0)
"Awesome OS Server Bits"

^^ taken at state of the screenshot
Comment 8 J.C. Molet 2012-03-21 13:08:23 EDT
Created attachment 571774 [details]
my subs mostly fixed

subscription-manager-gnome-0.99.10-1.git.85.057ca98.el6.x86_64

Stacking ID Text, Start Date Text, and End Date Text all have names and are usable:

user> (tasks/ui gettextvalue "Subscription Manager" "Stacking ID Text")
"1"

user> (tasks/ui gettextvalue "Subscription Manager" "Start Date Text")
"03/20/2012"

user> (tasks/ui gettextvalue "Subscription Manager" "End Date Text")
"03/20/2013"

----- ^^ This portion of the bug ( comment 2 ) is verified ^^ ---------


The Bundled products table now has a name, but it is the same name as the other Bundled products table and its currently unusable.  It needs a different name.
Comment 9 J.C. Molet 2012-03-21 13:16:20 EDT
Created attachment 571779 [details]
my installed mostly fixed

subscription-manager-gnome-0.99.10-1.git.85.057ca98.el6.x86_64

"Certificate Status Text" and "Product Text" have working names now and are usable:

user> (tasks/ui gettextvalue "Subscription Manager" "Certificate Status Text")
"Covered by contract(s) 66 through 03/20/2013"

user> (tasks/ui gettextvalue "Subscription Manager" "Product Text")
"Awesome OS for x86_64 Bits"

--- ^^ Verified for comment 3 ^^ ---

"Subscription Text" has the same at-spi locator as "Subscription Text" from the other tabs and is not reliably readable.
Comment 10 J.C. Molet 2012-03-21 13:34:09 EDT
None of the items in comment 4 have been fixed, they still all share the same names and cannot be reliably accessed in automation.

Note that only the at-spi locator of the text field needs to be unique and not the actual field name.  Marking FailedQA
Comment 11 Alex Wood 2012-03-23 09:30:37 EDT
Committed 2e114f3b5b922fd14d642d9866e3db899c4a5148

Available subscription-manager-0.99.12+
Comment 14 J.C. Molet 2012-03-26 14:06:36 EDT
The issue was brought up in sprint review 39 that the SLA subscribe button should be renamed entirely ('Autosubscribe' was suggested).  If/when that gets changed, the 'All Available Subscribe' locator should be changed back to 'Subscribe'.

I'm marking this as FailedQA until the final word on that is given.
Comment 15 Michael Stead 2012-03-30 09:53:27 EDT
Do we have approval to change the name of the SLA subscribe button?
Comment 16 Bryan Kearney 2012-03-30 11:17:39 EDT
Sefler would like to see it. So lets try it.
Comment 17 Alex Wood 2012-03-30 12:53:42 EDT
Committed 248a23ca172d3998f94b807a3552ff05ebd71c94

Available in subscription-manager-0.99.13+
Comment 18 Alex Wood 2012-03-30 13:20:37 EDT
*** Bug 805594 has been marked as a duplicate of this bug. ***
Comment 19 J.C. Molet 2012-04-11 11:51:39 EDT
testing in: 

subscription-manager-gnome-1.0.0-1.git.11.f42a186.el6.x86_64


All of the dynamic text fields seem to follow the right schema and have unique names.  Additionally the auto-subscribe button and subscribe button are different and work as expected.

Marking VERIFIED.
Comment 21 errata-xmlrpc 2012-06-20 09:07:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.