Bug 803690 - Scalability Testing: Single user logged in can see pages paint if conductor database is loaded up with users, deployments, images
Scalability Testing: Single user logged in can see pages paint if conductor d...
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Linux
unspecified Severity medium
: 1.0.2
: ---
Assigned To: Imre Farkas
wes hayutin
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 08:32 EDT by Ronelle Landy
Modified: 2012-12-04 09:58 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Large numbers of users and instances in Conductor caused the main page to load slowly. This bug fix updates Conductor to include pagination, which reduces the page loading time.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 09:58:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Waiting for log in (269.47 KB, image/png)
2012-03-15 08:35 EDT, Ronelle Landy
no flags Details
Waiting for Monitor page to paint (235.18 KB, image/png)
2012-03-15 08:35 EDT, Ronelle Landy
no flags Details
Waiting for Monitor page to paint - larger number of instances (93.85 KB, image/png)
2012-03-15 08:36 EDT, Ronelle Landy
no flags Details

  None (edit)
Description Ronelle Landy 2012-03-15 08:32:28 EDT
Description of problem:

 - Loaded up the conductor database with 500+ users
 - Built and pushed 20 images to the mock provider
 - In a few concurrent sessions, launched 318 instances to the mock provider
 - Cleared browser cookies and cache
 - Logged in as a single admin user
 - Then could see the conductor pages paint as they were accessed 

 - - Log in to up to 10 seconds (see screenshot)
 - - Monitor page took a while to render completely (see screenshot)

 - With 40 users logged in to this one instance of conductor, the times to access pages are almost equivalent to those seen for 120+ users accessing pages in more lightly populated conductor. Times for the last users to access the conductor/pools (monitor)page are copied below:

917	18:43:13.597	instance launch group 2-8	/conductor/pools	640154	
918	18:43:13.597	instance launch group 2-20	/conductor/pools	640269	
919	18:43:13.598	instance launch group 2-24	/conductor/pools	641425	
920	18:43:13.598	instance launch group 2-10	/conductor/pools	641485	 

rpms tested:

rpm -qa |grep aeolus
rubygem-aeolus-cli-0.3.0-14.el6.noarch
aeolus-configure-2.5.0-18.el6.noarch
aeolus-all-0.8.0-41.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-0.8.0-41.el6.noarch
aeolus-conductor-daemons-0.8.0-41.el6.noarch
aeolus-conductor-doc-0.8.0-41.el6.noarch


Additional info:
Comment 1 Ronelle Landy 2012-03-15 08:35:09 EDT
Created attachment 570279 [details]
Waiting for log in
Comment 2 Ronelle Landy 2012-03-15 08:35:51 EDT
Created attachment 570280 [details]
Waiting for Monitor page to paint
Comment 3 Ronelle Landy 2012-03-15 08:36:37 EDT
Created attachment 570281 [details]
Waiting for Monitor page to paint - larger number of instances
Comment 4 Angus Thomas 2012-03-16 12:28:40 EDT
Imre,

Can you please check whether the pagination patch you're working on helps with this?
Comment 5 Imre Farkas 2012-03-19 12:13:09 EDT
Yes, that patch will also fix this one.
Comment 6 Hugh Brock 2012-03-19 13:28:34 EDT
Pagination. 1.0.z.
Comment 7 Imre Farkas 2012-03-21 10:03:08 EDT
The pagination patch for BZ #802772 has been pushed to master so the performance of page loading should be better too.
Comment 9 Brad P. Crochet 2012-10-31 12:28:00 EDT
Verified. aeolus-all-0.13.22-1.el6cf.noarch
Comment 11 errata-xmlrpc 2012-12-04 09:58:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.