Bug 803733 - IndexError: list index out of range - when creating btrfs filesystem
IndexError: list index out of range - when creating btrfs filesystem
Status: CLOSED DUPLICATE of bug 787341
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:9b01d05657ed1132899e4d5f209...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 10:28 EDT by Mikko Tiihonen
Modified: 2012-03-15 11:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-15 11:42:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb-8mVLB0 (600.93 KB, text/plain)
2012-03-15 10:28 EDT, Mikko Tiihonen
no flags Details

  None (edit)
Description Mikko Tiihonen 2012-03-15 10:28:35 EDT
libreport version: 2.0.8
cmdline:        /usr/bin/python  /sbin/anaconda --graphical --selinux --repo cdrom:///dev/sr0:/mnt/install/source
executable:     /sbin/anaconda
exnFileName:    /tmp/anaconda-tb-8mVLB0
hashmarkername: anaconda
kernel:         3.3.0-0.rc6.git0.2.fc17.x86_64
other involved packages: 
product:        Fedora
reason:         IndexError: list index out of range
release:        Cannot get release name.
time:           Thu 15 Mar 2012 04:26:29 PM EET
version:        17-Beta-TC1

anaconda-tb-8mVLB0: Binary file, 615355 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 17.12 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 946, in addDevice
:    btrfs_dev = self.storage.devicetree.getChildren(device)[0]
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1096, in populate
:    self.addDevice(device, iter)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1649, in refresh
:    self.populate()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1712, in editPartition
:    if self.refresh(justRedraw=not actions):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1670, in editCB
:    self.editPartition(device)
:IndexError: list index out of range

environ:
:LC_NUMERIC=C
:LANGKEY=en
:LVM_SUPPRESS_FD_WARNINGS=1
:initrd=initrd.img
:GCONF_GLOBAL_LOCKS=1
:PATH=/tmp/product:/tmp/updates:/usr/bin:/bin:/sbin:/usr/sbin:/mnt/sysimage/bin:/mnt/sysimage/usr/bin:/mnt/sysimage/usr/sbin:/mnt/sysimage/sbin:/sbin:/usr/sbin
:PIXMAPPATH=/tmp/updates/pixmaps/:/tmp/updates/:/tmp/product/pixmaps/:/tmp/product/:pixmaps/:/usr/share/anaconda/pixmaps/:/usr/share/pixmaps/:/usr/share/anaconda/:/usr/share/python-meh/:/usr/share/icons/Fedora/48x48/apps/
:HOME=/tmp
:DISPLAY=:1
:LANG=en_US.UTF-8
:TERM=linux
:TZ=Europe/Helsinki
:XAUTHORITY=/root/.Xauthority
:GLADEPATH=/tmp/updates/:/tmp/updates/data/ui/:ui/:/usr/share/anaconda/ui/:/usr/share/python-meh/
:SHLVL=0
:LIBUSER_CONF=/tmp/libuser.ZkEPo6
:LD_LIBRARY_PATH=/tmp/product:/tmp/updates
:GNOME_DISABLE_CRASH_DIALOG=1
:PYTHONPATH=/tmp/product:/tmp/updates:/tmp/updates
:LINGUAS=English
:BOOT_IMAGE=vmlinuz
:LC_COLLATE=C
:PWD=/
:MALLOC_PERTURB_=MALLOC_PERTURB_=237
:MALLOC_CHECK_=2
Comment 1 Mikko Tiihonen 2012-03-15 10:28:40 EDT
Created attachment 570309 [details]
File: anaconda-tb-8mVLB0
Comment 2 Mikko Tiihonen 2012-03-15 10:40:36 EDT
My goal was to test installing on a btrfs raid0 filesystem without LVM or MD.

I ran the installer in kvm and chose the following options:
- added two virtio disks to install process
- cleared all existing partitions
- unchecked "use LVM"
- checked review and modify partitions

either of these will fail always:
- if I do a "create" -> normal parition -> btrfs filesystem -> save
- if I modify existing "/" ext4 filesystem type to btrfs filesystem -> save
Comment 3 Chris Lumens 2012-03-15 11:42:26 EDT

*** This bug has been marked as a duplicate of bug 787341 ***

Note You need to log in before you can comment on or make changes to this bug.