Bug 80384 - graphic install fails on Dell Latitude c800
graphic install fails on Dell Latitude c800
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-25 11:27 EST by Need Real Name
Modified: 2007-04-18 12:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:55:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-12-25 11:27:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Graphic install fails on a Dell Latitude c800 laptop.  After the graphic install
fails, the installer switches to text mode, which works OK.

This laptop has an ATI Rage 128 Mobility video card, from /proc/pci:
"VGA compatible controller: ATI Technologies Inc Rage Mobility M4 AGP (rev 0)."
 The LCD has 1600x1200 resolution.

The installer does set up X correctly, and X starts fine after rebooting from
the install.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Insert CD & boot
2. Select graphic mode for install
3. Wait...
    

Actual Results:  Graphic install fails, switched to text mode.

Expected Results:  Graphic install should work.

Additional info:

From "/tmp/X.log" file:

(++) Logfile: "/dev/null", Time...
(++) Using config file: "/tmp/XF86Config.test"
(EE) Failed to load module "glx" (module does not exist, 0)
(EE) VESA(0): No matching modes
(EE) Screen(s) found, but  none have a usable configuration.

Fatal server error:
no screens found



From VC3:

* ddcprobe returned bogus values:  
ID: None
Name: None
HorizSync: None
VertSync: None

* X startup failed, falling back to text mode

* anaconda floppy device hdc
Comment 1 Jeremy Katz 2002-12-25 22:57:42 EST
Does it work if you boot with 'linux resolution=1600x1200'?
Comment 2 Need Real Name 2002-12-26 11:35:34 EST
Yes, the 'linux resolution=1600x1200' option does get me into the graphic install.

It looks like the first attempt by the installer fails, but the second attempt
(VESA driver) works.  From VC1:
Attempting to start native X server
Waiting for X server to start...log in /tmp/X.log
1...2...3...4...5...X SERVER FAILEDAttempting to start VESA driver X server
Waiting for X server to start...log in /tmp/X.log
1...2...3...4...5...X SERVER started successfully


I managed to miss the 'resolution' option because I was looking in the wrong
places:  the release notes, and under the '[F2] Options' menu during the
install, and not under the '[F3] General' menu.  

I suggest a small reorganization of the initial text menus:  list all options
under '[F2] Options', and title the [F3] option something like 'Help', or
'Install Help'.  I also suggest that all of the boot options be documented in
the RELEASE_NOTES or README files.  

Making the boot options more salient could help some users self-diagnose install
problems.

Comment 3 Jeremy Katz 2003-01-10 01:37:33 EST
All of the boot options are documented in a file in the anaconda package as well
as an appendix of the installation guide.  

Mike, have you heard of any problems with the ATI laptop chips in the beta?
Comment 4 Mike A. Harris 2003-01-14 15:34:20 EST
(EE) Failed to load module "glx" (module does not exist, 0)
(EE) VESA(0): No matching modes
(EE) Screen(s) found, but  none have a usable configuration.

If the installer is going to remove XFree86 modules that aren't needed
during installation, then it needs to use a config file that does not
try to load modules that aren't needed during installation too.  Don't
tell it to load "glx" unless the glx module is present on the installation
media.  Ditto for other modules.

There are various open ATI laptop related bugs, but I don't have any
ATI laptop, nor any similar non-laptop hardware with which to reproduce
a problem or really troubleshoot.  Since there are bugs open that are
just as or more important than ATI laptop related bugs however, and I
do have the hardware for many of those, I've put priorities on the hardware
that I do have.

There are some recent changes in CVS that will be in a build soon concerning
incorrect horizontal polarity on some ATI chips.  I'm not sure what family
it was though.  The problem basically results in some resolutions being
unuseable if I understand correctly.

Might want to query bugzilla for similar reports and dupe this against
one if there's an identical report.  If there's no dupe, feel free to
reassign to me.

Seeing the entire XFree86 log might shed additional light too.
Comment 5 Michael Fulbright 2003-01-22 12:32:24 EST
Well we cannot probe LCD characteristics usually, and the installer assumes a
800x600x60HZ monitor settings to be safe when its cant determine the monitor
type.  For some reason the ATI driver does not let you run an LCD at less than
its native resolution, so when we specify a mode of 800x600 it throws it out.

The glx thing is annoying but completely unrelated.  I'll see if changing the X
configuration backend (which is shared with other tools) is possible to not
write out the line.

I have a hack to try and fix this but it wasnt in the latest beta.

Please look at bug 82428 for instructions on a workaround that you can try.

Let me know if it helps.
Comment 6 Need Real Name 2003-01-27 19:07:41 EST
Graphic install continues to fail on this laptop, even when using the latest
beta (phoebe 2, 8.0.93).

Briefly, the graphic install fails, even with the "linux resolution=1600x1200"
boot option (also see bug 72088).  The error message is:

XIO:  fatal IO error 104 (Connection reset by peer) on X server ":1.0"
      after 0 requests (0 known processed) with 0 events remaining.
install exited abnormally
Comment 7 Michael Fulbright 2003-01-30 15:58:53 EST
I will have to see if we have one of these available for testing.
Comment 8 Jeremy Katz 2003-02-11 01:24:33 EST
This should be happier post-phoebe2
Comment 9 Need Real Name 2003-02-20 22:50:27 EST
I just tried a graphic install of the phoebe beta 3, using the "linux
resolution=1600x1200" option.  I get the same result as beta 2 -- the graphic
install fail with this error message:

XIO:  fatal IO error 104 (Connection reset by peer) on X server ":1.0"
      after 0 requests (0 known processed) with 0 events remaining.
install exited abnormally
Comment 10 Need Real Name 2003-05-07 14:34:58 EDT
Update:  the same bug is present in RH9 -- graphic install fails with: 

XIO:  fatal IO error 104 (Connection reset by peer) on X server ":1.0"
      after 0 requests (0 known processed) with 0 events remaining.
install exited abnormally
Comment 11 Brent Fox 2003-05-25 10:55:50 EDT
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.

Note You need to log in before you can comment on or make changes to this bug.