Bug 803878 - Eclipse crashes by cairo problem
Eclipse crashes by cairo problem
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cairo (Show other bugs)
17
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Benjamin Otte
Fedora Extras Quality Assurance
:
: 803710 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 15:37 EDT by Alexander Kurtakov
Modified: 2012-04-11 22:18 EDT (History)
2 users (show)

See Also:
Fixed In Version: cairo-1.10.2-7.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-16 04:25:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Kurtakov 2012-03-15 15:37:59 EDT
Trying to run eclipse on F-17 crashes with:
java: cairo-image-surface.c:1320: _pixel_to_solid: Assertion `!"reached"'
failed.

This seems to be fixed by https://bugs.freedesktop.org/show_bug.cgi?id=37916. I applied the patch, rebuilt cairo and reinstalled it and Eclipse starts up again. Can we get the patch applied in Fedora 17?
Comment 1 Fedora Update System 2012-03-15 16:35:03 EDT
cairo-1.10.2-7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/cairo-1.10.2-7.fc17
Comment 2 Krzysztof Daniel 2012-03-16 04:25:05 EDT
Eclipse works with the above cairo build.
Comment 3 Krzysztof Daniel 2012-03-16 04:28:55 EDT
*** Bug 803710 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2012-04-11 22:18:52 EDT
cairo-1.10.2-7.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.