This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 803923 - RFE: email should be able to corrected during register validation.
RFE: email should be able to corrected during register validation.
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
1.6-SNAPSHOT
Unspecified Unspecified
high Severity high
: ---
: 2.1
Assigned To: Alex Eng
Ding-Yi Chen
:
: 735892 864088 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 21:52 EDT by Joyce Chang
Modified: 2013-03-03 22:19 EST (History)
8 users (show)

See Also:
Fixed In Version: 2.1-SNAPSHOT (20121220-0033)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 23:06:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Server Log (39.03 KB, text/x-log)
2012-12-17 21:36 EST, Ding-Yi Chen
no flags Details

  None (edit)
Description Joyce Chang 2012-03-15 21:52:58 EDT
Description of problem:

a typo during the process of register(e.g. wrong email address)result in failure of account activation. 

users should be able to go back and fix incorrect info for successful account activation (e.g. correcting email address ) 


Version-Release number of selected component (if applicable):
Zanata version 1.6-SNAPSHOT (20120315-1806). 


How reproducible:
always


Steps to Reproduce:
1.register
2.fill in all correct info except for wrong email address
3.register sent 
4. sign in 

  
Actual results:

unable to sign in, and no way to change email address 

Expected results:

able to to sign in and email can be changed in the profile

Additional info:
Comment 1 Runa Bhattacharjee 2012-07-30 09:27:49 EDT
Generally, in these cases a failure notice is displayed on the sign up page if the email address is not valid. If the email address is valid, but not the one the user intended it to be then the confirmation period comes with a timeout (24 hours in most cases), after which the user can sign up again (provided the other unrelated account holder did not activate the account). 

Do we have a timeout?
Comment 2 David Mason 2012-07-30 20:39:42 EDT
There is currently no timeout for validation emails. There is no expiration of validation emails at all, even if they have been used previously (see https://bugzilla.redhat.com/show_bug.cgi?id=750104).
Comment 3 Sean Flanigan 2012-07-30 22:35:23 EDT
Note that approx 99.999% of systems which attempt to pre-validate email addresses (on the sign-up page) get it wrong, and disallow perfectly valid addresses, because the programmer didn't expect to see a full-stop in an address, for example.

We should implement a timeout for validation emails, and for deleting unactivated accounts.

Note that the fix for this issue may require somewhat different handling for external authentication systems.  With internal authentication, users can always pick another username and try again with a different email address, but with external authentication, the username is determined for them, so they don't even have that option.
Comment 4 Ding-Yi Chen 2012-11-05 20:18:30 EST
*** Bug 735892 has been marked as a duplicate of this bug. ***
Comment 5 Patrick Huang 2012-11-20 00:38:37 EST
*** Bug 864088 has been marked as a duplicate of this bug. ***
Comment 6 Alex Eng 2012-12-17 00:45:02 EST
Implemented option to change email/resend activation email for unactivated account.


See 
https://github.com/zanata/zanata/commit/b56bd04ad7b8b27ce60032b055e451e32367e024
https://github.com/zanata/zanata/commit/01212c70f11a7a388732285f80b71c688510ed4e
https://github.com/zanata/zanata/commit/de8d6ba863266890f52d6eb86a0b7b4f260f0878
https://github.com/zanata/zanata/commit/c85e4f6d8d0a6177d2b0678cafe1deb1c98e2fd1
https://github.com/zanata/zanata/commit/99c406f08646e9d92af3edc1cbaa9e1ebcb4b82c
https://github.com/zanata/zanata/commit/1fab848962c6b657915a118aff5d5b36cbc0a54d
https://github.com/zanata/zanata/commit/31068aee683ab0fe0e6fef14cc7b3eec2b9cce17
https://github.com/zanata/zanata/commit/d64f8ff25a3bafd82b3a9917a347e2fffb17b709
https://github.com/zanata/zanata/commit/979efbd8229d2a01249cdc97c0d8ebddefd695df
https://github.com/zanata/zanata/commit/f4bf58bfeb91878be5c7d3d78d4520f7407018f6
https://github.com/zanata/zanata/commit/63d136e49e07fe2036b04ee86903467b4605327c
https://github.com/zanata/zanata/commit/ba264faf104b37083299547b11a96e4067df45fc
https://github.com/zanata/zanata/commit/8a5326d4f2e9b05cf4f1afcd04811494d0c2a488
https://github.com/zanata/zanata/commit/8106f562294a048b0e66413336418a6e6f613304
https://github.com/zanata/zanata/commit/a9a685bc0e3d6503b521769c70b872628afbe184
https://github.com/zanata/zanata/commit/01827084fc8f90f8a429d59560eda8391f42b1ef
https://github.com/zanata/zanata/commit/b689e4ca7b75ba3a7b83385ae0469b881f86e53d
Comment 7 Ding-Yi Chen 2012-12-17 21:36:24 EST
Created attachment 665242 [details]
Server Log
Comment 8 Ding-Yi Chen 2012-12-17 21:38:43 EST
Tested with Zanata version 2.1-SNAPSHOT (20121217-1536)

Unexpected error. Please try again. [ Request: /error.seam?cid=18 ] 
appears after either Resend activation email or Update email address.

Note that server setting is done through the zanata.properties

Server log is attached in previous comment.
Comment 11 Ding-Yi Chen 2012-12-19 18:17:55 EST
VERIFIED with Zanata version 2.1-SNAPSHOT (20121220-0033)

Note You need to log in before you can comment on or make changes to this bug.