Bug 803956 - (spice) Mouse cursor could not find in the guest when using qxl with VNC
(spice) Mouse cursor could not find in the guest when using qxl with VNC
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-common (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Uri Lublin
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-16 02:00 EDT by Mike Cao
Modified: 2014-07-15 06:52 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-24 04:32:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Cao 2012-03-16 02:00:00 EDT
Description of problem:


Version-Release number of selected component (if applicable):
[root@amd-2376-32-1 test]# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.248.el6rhev.x86_64
[root@amd-2376-32-1 test]# uname -r
2.6.32-252.el6.x86_64

win2k8R2 guest

How reproducible:
100%

Steps to Reproduce:
1.start guest with qxl and vnc at the same use 
CLI :/usr/libexec/qemu-kvm -M rhel6.3.0 -enable-kvm -m 8192 -smp 4,sockets=4,cores=1,threads=1 -name win2k8-R2 -uuid e2eaca3e-e764-f57b-22f0-74f4ab8c4965 -monitor stdio -rtc base=localtime,driftfix=slew -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=/test/win2k8r2,if=none,id=drive-ide0-0-0,format=raw,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -drive file=/root/en_windows_server_2008_r2_standard_enterprise_datacenter_and_web_with_sp1_x64_dvd_617601.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:15:af:6a,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -device usb-tablet,id=input0 -vnc :1 -vga qxl -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x5  -bios /bios-tttt.bin

  
Actual results:
the is a point instead of the mouse cursor 

Expected results:
in the guest mouse cursor should displayed 

Additional info:
-spice -vga qxl will not hit this issue .
Comment 3 Marian Krcmarik 2012-03-20 07:18:03 EDT
This is not supported combination right now - qxl+vnc in kvm, see comment from Dor: https://bugzilla.redhat.com/show_bug.cgi?id=717373#c2
Comment 4 Suzanne Yeghiayan 2012-03-21 16:16:55 EDT
This request was evaluated by Red Hat Product Management for inclusion in the
current release of Red Hat Enterprise Linux. Because the affected component is
not scheduled to be updated in the current release, Red Hat is unfortunately
unable to address this request at this time.  It has been proposed for the next
release. If you would like it considered as an exception in the current
release, please ask your support representative.
Comment 5 Alon Levy 2012-07-23 15:28:18 EDT
Mike,

 Does it happen if no qxl driver is loaded in the guest?

Alon
Comment 6 Uri Lublin 2012-07-24 04:32:49 EDT
Following Marian's comment 3 and bug 717373, since this qxl+vnc is not supported,
closing as wontfix

Note You need to log in before you can comment on or make changes to this bug.