Bug 804007 - [abrt] kernel: WARNING: at lib/debugobjects.c:262 debug_print_object+0x8c/0xb0()
[abrt] kernel: WARNING: at lib/debugobjects.c:262 debug_print_object+0x8c/0xb0()
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
abrt_hash:91dd668c9e9eff4c7542a59a677...
:
: 804434 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-16 05:48 EDT by Misha Shnurapet
Modified: 2012-04-11 22:02 EDT (History)
8 users (show)

See Also:
Fixed In Version: kernel-3.3.0-5.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-21 21:57:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: smolt_data (2.88 KB, text/plain)
2012-03-16 05:49 EDT, Misha Shnurapet
no flags Details

  None (edit)
Description Misha Shnurapet 2012-03-16 05:48:57 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/boot/vmlinuz-3.3.0-0.rc7.git0.3.fc17.x86_64 root=UUID=0d6ad8c6-d92e-4bbc-b1ee-b9bfbe9d6c3b ro rd.md=0 rd.lvm=0 rd.dm=0 SYSFONT=True rd.luks=0 KEYTABLE=us-acentos LANG=en_US.UTF-8 rhgb quiet nomodeset
kernel:         3.3.0-0.rc7.git0.3.fc17.x86_64
reason:         WARNING: at lib/debugobjects.c:262 debug_print_object+0x8c/0xb0()
time:           Пт. 16 марта 2012 04:27:13

smolt_data:     Binary file, 2952 bytes

backtrace:
:WARNING: at lib/debugobjects.c:262 debug_print_object+0x8c/0xb0()
:Hardware name: System Product Name
:ODEBUG: free active (active state 0) object type: timer_list hint: sta_rx_agg_reorder_timer_expired+0x0/0xf0 [mac80211]
:Modules linked in: binfmt_misc fuse be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i cxgb3 mdio libcxgbi ib_iser bnep rdma_cm bluetooth ib_addr iw_cm ib_cm ib_sa ib_mad ib_core iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi snd_hda_codec_hdmi arc4 snd_hda_codec_via snd_hda_intel ath9k_htc snd_hda_codec ath9k_common ath9k_hw ath ppdev snd_hwdep snd_pcm mac80211 nouveau cfg80211 mxm_wmi wmi rfkill video ttm snd_page_alloc snd_timer snd microcode drm_kms_helper drm soundcore serio_raw edac_core sp5100_tco k8temp edac_mce_amd i2c_piix4 asus_atk0110 parport_pc parport i2c_core uinput ata_generic pata_acpi usb_storage uas pata_atiixp [last unloaded: scsi_wait_scan]
:Pid: 10, comm: ksoftirqd/1 Tainted: G        W    3.3.0-0.rc7.git0.3.fc17.x86_64 #1
:Call Trace:
: [<ffffffff81060dff>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff81060ef6>] warn_slowpath_fmt+0x46/0x50
: [<ffffffff8133273c>] debug_print_object+0x8c/0xb0
: [<ffffffffa02815a0>] ? ieee80211_free_tid_rx+0x70/0x70 [mac80211]
: [<ffffffff813334d9>] debug_check_no_obj_freed+0x119/0x210
: [<ffffffffa028158d>] ? ieee80211_free_tid_rx+0x5d/0x70 [mac80211]
: [<ffffffffa028158d>] ? ieee80211_free_tid_rx+0x5d/0x70 [mac80211]
: [<ffffffff811a1d4e>] kfree+0xce/0x280
: [<ffffffff811125be>] ? __rcu_process_callbacks+0x14e/0x490
: [<ffffffffa028158d>] ieee80211_free_tid_rx+0x5d/0x70 [mac80211]
: [<ffffffff811125f2>] __rcu_process_callbacks+0x182/0x490
: [<ffffffff81069b09>] ? __do_softirq+0x89/0x380
: [<ffffffff8111292f>] rcu_process_callbacks+0x2f/0x250
: [<ffffffff81069b60>] __do_softirq+0xe0/0x380
: [<ffffffff81069f37>] run_ksoftirqd+0x137/0x210
: [<ffffffff81069e00>] ? __do_softirq+0x380/0x380
: [<ffffffff8108a477>] kthread+0xb7/0xc0
: [<ffffffff816a7fb4>] kernel_thread_helper+0x4/0x10
: [<ffffffff8169e374>] ? retint_restore_args+0x13/0x13
: [<ffffffff8108a3c0>] ? kthread_worker_fn+0x1a0/0x1a0
: [<ffffffff816a7fb0>] ? gs_change+0x13/0x13
Comment 1 Misha Shnurapet 2012-03-16 05:49:10 EDT
Created attachment 570547 [details]
File: smolt_data
Comment 2 John W. Linville 2012-03-16 13:14:57 EDT
I have no idea what this is -- can you repeat it?  What were you doing when it happened?
Comment 3 Misha Shnurapet 2012-03-16 22:52:33 EDT
This is all I have, sorry. Maybe a better backtrace on another occurence.
Comment 4 Stanislaw Gruszka 2012-03-19 08:03:28 EDT
I think I understand this race condition ...
Comment 5 Stanislaw Gruszka 2012-03-19 11:09:03 EDT
Posted proposed fix:
http://marc.info/?l=linux-wireless&m=133216930411065&w=2
Comment 6 Stanislaw Gruszka 2012-03-20 07:52:49 EDT
Josh, please apply fix from above comment.
Comment 7 Josh Boyer 2012-03-20 08:38:11 EDT
(In reply to comment #6)
> Josh, please apply fix from above comment.

Gladly.  I'll get this into all branches today.
Comment 8 Josh Boyer 2012-03-20 08:54:26 EDT
(In reply to comment #7)
> (In reply to comment #6)
> > Josh, please apply fix from above comment.
> 
> Gladly.  I'll get this into all branches today.

Committed to Fedora git.  Thanks Stanislaw.
Comment 9 Fedora Update System 2012-03-20 15:22:42 EDT
kernel-2.6.42.12-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/FEDORA-2012-3715/kernel-2.6.42.12-1.fc15
Comment 10 Fedora Update System 2012-03-20 19:26:11 EDT
kernel-3.3.0-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.3.0-4.fc16
Comment 11 Fedora Update System 2012-03-21 21:57:00 EDT
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-03-26 09:40:59 EDT
kernel-3.3.0-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.3.0-5.fc17
Comment 13 Fedora Update System 2012-03-26 14:02:49 EDT
kernel-2.6.42.12-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Stanislaw Gruszka 2012-04-04 07:06:06 EDT
*** Bug 804434 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Update System 2012-04-11 22:02:06 EDT
kernel-3.3.0-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.