Bug 804039 - Pollutes /usr/lib/python2.7/site-packages/tests with its test suite
Pollutes /usr/lib/python2.7/site-packages/tests with its test suite
Status: CLOSED DUPLICATE of bug 797813
Product: Fedora
Classification: Fedora
Component: python-paste-script (Show other bugs)
17
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-16 07:38 EDT by Daniel Berrange
Modified: 2016-09-19 22:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-19 10:11:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2012-03-16 07:38:25 EDT
Description of problem:
These private unit tests should not be installed in the RPM, not least because they clash with other (bogusly installed) test files from python-boto. This prevents installation of openstack in Fedora 17 updates-testing

# rpm -ql python-paste-script | grep /usr/lib/python2.7/site-packages/tests
/usr/lib/python2.7/site-packages/tests
/usr/lib/python2.7/site-packages/tests/__init__.py
/usr/lib/python2.7/site-packages/tests/__init__.pyc
/usr/lib/python2.7/site-packages/tests/__init__.pyo
/usr/lib/python2.7/site-packages/tests/appsetup
/usr/lib/python2.7/site-packages/tests/appsetup/__init__.py
/usr/lib/python2.7/site-packages/tests/appsetup/__init__.pyc
/usr/lib/python2.7/site-packages/tests/appsetup/__init__.pyo
/usr/lib/python2.7/site-packages/tests/appsetup/test_make_project.py
/usr/lib/python2.7/site-packages/tests/appsetup/test_make_project.pyc
/usr/lib/python2.7/site-packages/tests/appsetup/test_make_project.pyo
/usr/lib/python2.7/site-packages/tests/test_egg_finder.py
/usr/lib/python2.7/site-packages/tests/test_egg_finder.pyc
/usr/lib/python2.7/site-packages/tests/test_egg_finder.pyo
/usr/lib/python2.7/site-packages/tests/test_logging_config.py
/usr/lib/python2.7/site-packages/tests/test_logging_config.pyc
/usr/lib/python2.7/site-packages/tests/test_logging_config.pyo
/usr/lib/python2.7/site-packages/tests/test_plugin_adder.py
/usr/lib/python2.7/site-packages/tests/test_plugin_adder.pyc
/usr/lib/python2.7/site-packages/tests/test_plugin_adder.pyo
/usr/lib/python2.7/site-packages/tests/test_template_introspect.py
/usr/lib/python2.7/site-packages/tests/test_template_introspect.pyc
/usr/lib/python2.7/site-packages/tests/test_template_introspect.pyo

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Berrange 2012-03-16 07:48:04 EDT
This problem was missed because of badly designed %files rules:

  %files
  %defattr(-,root,root,-)
  %doc docs/*
  %{python_sitelib}/*

This last line should be rewritten as

  %{python_sitelib}/PasteScript-*
  %{python_sitelib}/paste

So that future RPM updates will error out at build time if bogus files get dropped into the sitelib directory.
Comment 2 Luke Macken 2012-03-19 10:11:17 EDT

*** This bug has been marked as a duplicate of bug 797813 ***

Note You need to log in before you can comment on or make changes to this bug.