Bug 804150 - Unchecked error in _libssh2_channel_write results in infinite loop
Summary: Unchecked error in _libssh2_channel_write results in infinite loop
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libssh2
Version: 6.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Kamil Dudka
QA Contact: Karel Srot
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-16 16:30 UTC by Matthew Booth
Modified: 2013-02-21 08:42 UTC (History)
4 users (show)

Fixed In Version: libssh2-1.4.2-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 08:42:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0329 normal SHIPPED_LIVE libssh2 bug fix and enhancement update 2013-02-20 20:54:28 UTC

Description Matthew Booth 2012-03-16 16:30:26 UTC
Description of problem:
This bug is fixed upstream. See mailing list discussion here:

http://www.libssh2.org/mail/libssh2-devel-archive-2012-03/0068.shtml

It's fixed in upstream commit fed075972080ed705bd79b731c40cf5e73085aeb.

virt-p2v hits this if bug 804145 isn't fixed. Assuming bug 804145 will be fixed, this one probably isn't critical. However, it did severely hamper debugging until I found it.

Version-Release number of selected component (if applicable):
libssh2-1.2.2-7.el6_1.1.x86_64

Comment 2 Kamil Dudka 2012-03-19 14:27:09 UTC
Thank you for reporting the bug and getting it fixed upstream, Matthew.  I have built a Fedora package (libssh2-1.4.0-4.fc18) with this fix included for now.

Comment 3 Karel Srot 2012-08-14 13:45:38 UTC
Hi Kamil, 
could you please provide a reproducer?

Comment 4 Kamil Dudka 2012-08-26 22:45:21 UTC
I do not have any atm, will try to reproduce as time permits...

Comment 7 RHEL Program Management 2012-09-12 12:41:21 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 13 RHEL Program Management 2012-10-12 06:30:57 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 16 errata-xmlrpc 2013-02-21 08:42:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0329.html


Note You need to log in before you can comment on or make changes to this bug.