This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 804209 - Crashing gnome session with openbox core
Crashing gnome session with openbox core
Status: CLOSED DUPLICATE of bug 827800
Product: Fedora
Classification: Fedora
Component: openbox (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-16 16:26 EDT by Zdenek Kabelac
Modified: 2012-06-06 03:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 03:46:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full backtrace (16.45 KB, application/octet-stream)
2012-03-16 16:26 EDT, Zdenek Kabelac
no flags Details

  None (edit)
Description Zdenek Kabelac 2012-03-16 16:26:26 EDT
Created attachment 570699 [details]
Full backtrace

Description of problem:

Pretty straightforward core

0  0x00007febbec6d915 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x00007febbec6f0c8 in __GI_abort () at abort.c:91
#2  0x00007febbeff8212 in sighandler (sig=<optimized out>) at obt/signal.c:281
#3  <signal handler called>
#4  client_configure (self=0x0, x=25, y=158, w=1159, h=778, user=user@entry=1, final=final@entry=1, force_reply=force_reply@entry=0)
    at openbox/client.c:3057
#5  0x0000000000436a2c in moveresize_end (cancel=cancel@entry=1) at openbox/moveresize.c:333
#6  0x0000000000427d54 in event_handle_client (e=0x7fffadfe0280, client=0x1ad66c0) at openbox/event.c:1491
#7  event_process (ec=<optimized out>, data=<optimized out>) at openbox/event.c:625
#8  0x00007febbeff9191 in event_read (source=source@entry=0x1ac5f90, callback=<optimized out>, data=<optimized out>) at obt/xqueue.c:338
#9  0x00007febc032c73c in g_main_dispatch (context=0x1a5a300) at gmain.c:2510
#10 g_main_context_dispatch (context=context@entry=0x1a5a300) at gmain.c:3047
#11 0x00007febc032cb58 in g_main_context_iterate (context=0x1a5a300, block=block@entry=1, dispatch=dispatch@entry=1, 
    self=<error reading variable: Unhandled dwarf expression opcode 0xfa>) at gmain.c:3118
#12 0x00007febc032cf42 in g_main_loop_run (loop=0x1a6b770) at gmain.c:3312
#13 0x000000000040f47e in main (argc=1, argv=0x7fffadfe0788) at openbox/openbox.c:378

The reason is  NULL moveresize_client -  number of sulutions seems to be them
quickest could be to just skip operation if it's NULL, but it looks on some
synchronization problem.



Version-Release number of selected component (if applicable):
openbox-3.5.0-4.fc17.x86_64
openbox-gnome-3.5.0-4.fc17.x86_64
openbox-libs-3.5.0-4.fc17.x86_64


How reproducible:


Steps to Reproduce:
1. During some window resize or move operation click/double click on titlebar.
2.
3.
  
Actual results:

Expected results:
Not crashing Xsession 1-2 per day

Additional info:
Comment 1 Edward Sheldrake 2012-04-03 04:08:58 EDT
I've also experienced this since upgrading from gtk3 3.2 to 3.4.

Reported upstream: https://bugzilla.icculus.org/show_bug.cgi?id=5460
Comment 2 Zdenek Kabelac 2012-05-29 09:39:05 EDT
Any chance trying to make a build for Fedora with patch attached in the BZ from comment 1.

It's really annoying to get those crashes with openbox all the time.
Comment 3 Zdenek Kabelac 2012-06-06 03:46:14 EDT

*** This bug has been marked as a duplicate of bug 827800 ***

Note You need to log in before you can comment on or make changes to this bug.