Bug 827800 - [abrt] openbox-3.5.0-5.fc17: __GI_raise: Process /usr/bin/openbox was killed by signal 6 (SIGABRT)
[abrt] openbox-3.5.0-5.fc17: __GI_raise: Process /usr/bin/openbox was killed ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openbox (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
abrt_hash:6489bde584cb59c47293dd3c593...
:
: 781984 804209 810869 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-03 00:57 EDT by Ross Lagerwall
Modified: 2012-06-19 20:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 20:33:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: maps (28.65 KB, text/plain)
2012-06-03 00:57 EDT, Ross Lagerwall
no flags Details
File: backtrace (20.71 KB, text/plain)
2012-06-03 00:57 EDT, Ross Lagerwall
no flags Details
Patch which fixes the issue. (992 bytes, patch)
2012-06-03 14:44 EDT, Ross Lagerwall
no flags Details | Diff

  None (edit)
Description Ross Lagerwall 2012-06-03 00:57:30 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        openbox
crash_function: __GI_raise
executable:     /usr/bin/openbox
kernel:         3.3.7-1.fc17.x86_64
pid:            853
pwd:            /home/ross
time:           Sat 02 Jun 2012 05:20:41 PM SAST
uid:            1000

backtrace:      Text file, 21207 bytes
maps:           Text file, 29334 bytes

build_ids:
:ff1ddc50279cd39ef3771cc64010e32b72226a4d
:99c23b21038c62b0628b93610fb54c5900c40ffd
:f7b77d031477028aae037993d39e8b111e38aab1
:b7eca209ddde67c74201baeee61870e17b971a20
:dec0de92024bee74c75c04bde4c54c097fe68ae8
:ac9ef4eb50bc86fe203a793054836ee9063ab22e
:5b4f3d35b4612be98f2bbb635b3eabf0ee7e437d
:a8efbe1d263ad42afae74bc027eee88eaa754f55
:ac8ffc8f82d7f2e7fb574c927bc25702f59c2547
:ff5a0c299ee54a2580475ad0d6cae351ec6cd4f6
:66ff6e23f48b16dd1cd292e31a109a8c98ff70f2
:b277af36744327e3d58eae76bcdaadcca71a28c6
:a32b5579ea85f99dcbb2cb03ab5182473779aa32
:76f0ca2cc5c8796e9d6efbe21d74250166974af9
:e91010b497ec024178c36f4365b21f668bada0ca
:31243d0d107bba586a96433c76c87a26db1e826c
:aa38f6a8b3b580c14baed61961e86b8fcb194ace
:80646a9d3725f952b8c5738700de3ce2a19394f5
:855f5a9b1e16a35c8f7bd3528cecfc7b24102d14
:1555b1de25ee9aa6770b016dc6b0fc0372c073bd
:f64b7319b84d426ed547084bdb2577f4f596c18f
:877685c5afa0faf0e43ad65f21587f699edcc04d
:127f8958b602715234a02b88adb08afd9e34c203
:b8bfc491895389962d926fdc99cbfbac571f2cf0
:18ab41b0cf15268048869496abd79603c3906cda
:51df4cbbc11bdab5dfc33ed3fd5782b8a5c7602d
:63651cdc0224824a9c9324c77c3b5887378e871d
:c4ec0971b2dcee71aaf8374975474054245fea00
:7ae6667ed513174e52f2bc0f121cd56d8cad1dc4
:822e9b3523e8312240f41a25722d539bc77ed436
:73777e822e00ca152ffca281ab0ace0cb498ec48
:6e3dbb942f7e173d65ea958bd449f6727b220abb
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65
:9dc7d977acebd2e8abf2d55bf2738ea2d89f7480
:7af89586a93d33f6be811c84629c429738ec61f0
:6e5d5649c704cd3a34cf145ccd2d08994f1e83ff
:4d09d82785dab5f95c01b69bc0785145a5954d30
:7c35310fc506498c612d5d982ab03becc4b4817c
:b7189216c8e5960dc1c7b6d083bbd3808a22074f
:ee6ae7b081f41e8f781e4aaadf2aeb12f84e4fce
:8f7c190397d7c1f617e66f18f759714662b60367
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202
:de8765a1f811be7af865204ba32ef7846307e863
:4b044fe80e4c1b69986abc4b160c303048005d4e
:c7db5c22878778db0ca8b7b0f6ecad79d695aecb
:bd0ac043ae8788e4131de24fa2becebf2ba97698
:54a5cc118d928470da13565de8592b664a9868e0
:4dac977c0337ed949981bfc9ec0c5c617eb0cc74
:5dd234206476b0387cd251598aa72a2c95c763c5
:271a2d91cc3308783ff4a7ab45049f31aa42d8b7
:0eeac854ab0b56d18d126ca7056136b4e63abed7
:1d4df97fa6024b097b634a272447243c95c26d85
:42a671919ec259710d222f25566dc31f9a4daef0
:130699b76d99d57ef46beeed9d693005f3c8917f
:1b7abd5c8129b91c0ca4f0f0812e61660236fd38
:247132297f287226a24c12e683292f5c94013066
:37c3e73fe1de5bf6feacd62c66a99fefc029b700
:5350b5972464f66f404861dc50225a114a2a5e7e

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/ross/1

comment:
:Simply running a GTK program under Openbox.
:
:It is caused by a change in GTK+ 3.4 and has been reported to upstream
:Openbox at https://bugzilla.icculus.org/show_bug.cgi?id=5460
:The upstream bug has a patch which seems to fix the issue.
:
:This is pretty severe -- it makes Openbox unusable for me (crashing
:every few minutes).

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=1
:HOSTNAME=hobo
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:SYSFONT=True
:GNOME_KEYRING_CONTROL=/home/ross/.cache/keyring-H3633X
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:USER=ross
:MAIL=/var/spool/mail/ross
:PATH=/usr/lib64/ccache:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/ross/.local/bin:/home/ross/bin
:DESKTOP_SESSION=Awesine
:QT_IM_MODULE=xim
:PWD=/home/ross
:XMODIFIERS=@im=none
:LANG=en_US.UTF-8
:GNOME_KEYRING_PID=605
:HISTCONTROL=ignoredups
:KEYTABLE=us
:SHLVL=1
:HOME=/home/ross
:XDG_SEAT=seat0
:BOOT_IMAGE=/vmlinuz-3.3.7-1.fc17.x86_64
:LOGNAME=ross
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-ocZrYgtqDj,guid=d7d5a07992b7dc753896f8a700000016
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:DISPLAY=:0
:XDG_RUNTIME_DIR=/run/user/ross
:GTK_IM_MODULE=gtk-im-context-simple
:CCACHE_HASHDIR=
:XAUTHORITY=/home/ross/.Xauthority
:_=/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/607,unix/unix:/tmp/.ICE-unix/607
:GPG_AGENT_INFO=/home/ross/.cache/keyring-H3633X/gpg:0:1
:SSH_AUTH_SOCK=/home/ross/.cache/keyring-H3633X/ssh
:DESKTOP_AUTOSTART_ID=109d91443d8d4d50ac133864311454371200000006070026

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 15824                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       15824                15824                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/var/log/lxdm.log
:pos:	2053
:flags:	0102001
:2:/home/ross/.xsession-errors
:pos:	3325
:flags:	0100001
:3:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:4:/home/ross/.cache/openbox/openbox.log
:pos:	0
:flags:	0100001
:5:socket:[16106]
:pos:	0
:flags:	02000002
:6:socket:[16349]
:pos:	0
:flags:	02004002

smolt_data:
:
:
:General
:=================================
:UUID: 7317cab1-e006-47f8-a852-a61e38b49e96
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 5941.68
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Duo CPU     E8400  @ 3.00GHz
:CPU Stepping: 6
:CPU Family: 6
:CPU Model Num: 23
:Number of CPUs: 2
:CPU Speed: 2970
:System Memory: 1995
:System Swap: 3999
:Vendor: ECS
:System: 945GCT-M2 1.x
:Form factor: Desktop
:Kernel: 3.3.7-1.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4332:33081:4121:33081) pci, 8139too, ETHERNET, RTL-8139/8139C/8139C+
:(32902:10098:4121:9779) pci, i915, VIDEO, 82945G/GZ Integrated Graphics Controller
:(32902:10176:4121:9779) pci, ata_piix, STORAGE, N10/ICH7 Family SATA IDE Controller
:(32902:10207:4121:9779) pci, ata_piix, STORAGE, 82801G (ICH7 Family) IDE Controller
:(32902:10168:4121:9779) pci, None, PCI/ISA, 82801GB/GR (ICH7 Family) LPC Interface Bridge
:(32902:10200:4121:9779) pci, snd_hda_intel, MULTIMEDIA, N10/ICH 7 Family High Definition Audio Controller
:(32902:10202:4121:9779) pci, i801_smbus, SERIAL, N10/ICH 7 Family SMBus Controller
:(32902:9294:4121:9779) pci, None, PCI/PCI, 82801 PCI Bridge
:(32902:10185:4121:9779) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #2
:(32902:10184:4121:9779) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #1
:(32902:10096:4121:9779) pci, agpgart-intel, HOST/PCI, 82945G/GZ/P/PL Memory Controller Hub
:(32902:10186:4121:9779) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #3
:(32902:10187:4121:9779) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #4
:(32902:10188:4121:9779) pci, ehci_hcd, USB, N10/ICH 7 Family USB2 EHCI Controller
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sdb5 / ext4 4096 4096 11930781 9589838 8992078 2990080 2776552 2776552
:/dev/sdb4 WITHHELD ext4 4096 4096 20937899 12690056 11641480 5242880 4360337 4360337
:/dev/sdb2 /boot ext4 1024 1024 508745 427942 402342 128016 127672 127672
:/dev/sdc4 WITHHELD ext4 4096 4096 13318138 11431586 10764386 3342336 3341066 3341066
:/dev/sdc3 WITHHELD ext4 4096 4096 25561025 4236124 2956124 6406144 6243847 6243847
:
Comment 1 Ross Lagerwall 2012-06-03 00:57:39 EDT
Created attachment 588784 [details]
File: maps
Comment 2 Ross Lagerwall 2012-06-03 00:57:44 EDT
Created attachment 588785 [details]
File: backtrace
Comment 3 Ross Lagerwall 2012-06-03 14:43:58 EDT
This bug has been marked as fixed upstream (https://bugzilla.icculus.org/show_bug.cgi?id=5460).

It would be nice if this patch could be incorporated into the Fedora package.

I have attached the upstream fix.
Comment 4 Ross Lagerwall 2012-06-03 14:44:42 EDT
Created attachment 588914 [details]
Patch which fixes the issue.
Comment 5 Christoph Wickert 2012-06-03 16:22:49 EDT
*** Bug 810869 has been marked as a duplicate of this bug. ***
Comment 6 Christoph Wickert 2012-06-03 16:24:43 EDT
*** Bug 781984 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2012-06-03 19:12:27 EDT
openbox-3.5.0-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/openbox-3.5.0-6.fc17
Comment 8 Fedora Update System 2012-06-05 19:03:05 EDT
Package openbox-3.5.0-6.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openbox-3.5.0-6.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8857/openbox-3.5.0-6.fc17
then log in and leave karma (feedback).
Comment 9 Zdenek Kabelac 2012-06-06 03:46:15 EDT
*** Bug 804209 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2012-06-19 20:33:43 EDT
openbox-3.5.0-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.