Bug 804279 - xterm - desktop file's icon missmatch the installed icons
xterm - desktop file's icon missmatch the installed icons
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
: 799614 847035 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-17 06:01 EDT by Nicolas Chauvet (kwizart)
Modified: 2012-11-11 06:08 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-11 06:08:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Chauvet (kwizart) 2012-03-17 06:01:53 EDT
Description of problem:
from fedora-xterm.desktop:
Icon=gnome-xterm
Whereas # rpm -ql xterm |grep pixmaps
/usr/share/pixmaps/xterm-color_32x32.xpm
/usr/share/pixmaps/xterm-color_48x48.xpm
/usr/share/pixmaps/xterm_32x32.xpm
/usr/share/pixmaps/xterm_48x48.xpm


Version-Release number of selected component (if applicable):
xterm-278-1.fc17

How reproducible:
always

Steps to Reproduce:
1. install xterm

  
Actual results:
There is no icon displayed

Expected results:


Additional info:

The icons have to be renamed to either xterm-color or xterm during %install and moved to the related directory of their size within /usr/share/icons/hicolor
Comment 1 Thomas E. Dickey 2012-06-05 06:53:52 EDT
This seems to be the same as #799614 (but provides more information).
Comment 2 Thomas E. Dickey 2012-06-12 17:40:14 EDT
Actually it is not technically necessary to rename or move the
icons (the packages that I build for testing work without this).
Putting them into a theme may appear "good" to remove clutter.
However those are not part of the hicolor package, and would
complicate updates by their presence.

I don't see any responses by Miroslav to the various icon issues.
Comment 3 Thomas E. Dickey 2012-06-27 07:36:45 EDT
xterm patch #281 is current, and as far as I know provides all
of the configurability needed by the packager to resolve this
issue.  Note that I changed the meaning of the --with-icondir
option (for consistency), which would affect package scripts.
Comment 4 Miroslav Lichvar 2012-10-09 09:37:43 EDT
*** Bug 799614 has been marked as a duplicate of this bug. ***
Comment 5 Miroslav Lichvar 2012-10-09 09:38:47 EDT
I'm looking into this.
Comment 6 Miroslav Lichvar 2012-10-10 10:55:40 EDT
*** Bug 847035 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2012-10-10 12:10:08 EDT
xterm-283-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xterm-283-1.fc18
Comment 8 Fedora Update System 2012-10-10 12:13:56 EDT
xterm-283-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xterm-283-1.fc17
Comment 9 Fedora Update System 2012-10-10 20:59:55 EDT
Package xterm-283-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xterm-283-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15860/xterm-283-1.fc17
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-10-15 07:17:56 EDT
xterm-284-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xterm-284-1.fc18
Comment 11 Fedora Update System 2012-10-15 07:19:28 EDT
xterm-284-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xterm-284-1.fc17
Comment 12 Fedora Update System 2012-11-08 01:11:08 EST
xterm-284-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.