Bug 804499 - KeyError: 'C'
KeyError: 'C'
Status: CLOSED DUPLICATE of bug 804483
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:93143400ce0cec5dc3bdabc777d...
:
Depends On:
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2012-03-19 01:28 EDT by Tao Wu
Modified: 2014-10-28 19:45 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-19 03:27:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb-RtHtfK (68.33 KB, text/plain)
2012-03-19 01:28 EDT, Tao Wu
no flags Details

  None (edit)
Description Tao Wu 2012-03-19 01:28:11 EDT
libreport version: 2.0.8
cmdline:        /usr/bin/python  /usr/sbin/anaconda
executable:     /usr/sbin/anaconda
exnFileName:    /tmp/anaconda-tb-RtHtfK
hashmarkername: anaconda
kernel:         3.3.0-0.rc7.git0.3.fc17.i686
other involved packages: 
product:        Fedora
reason:         KeyError: 'C'
release:        Cannot get release name.
time:           Mon Mar 19 05:26:48 2012
version:        17-Beta-TC2

anaconda-tb-RtHtfK: Text file, 69971 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 17.13 exception report
:Traceback (most recent call first):
:  File "/usr/lib/python2.7/site-packages/snack.py", line 193, in setCurrent
:    self.w.listboxSetCurrent(self.item2key[item])
:  File "/usr/lib/python2.7/site-packages/snack.py", line 806, in ListboxChoiceWindow
:    l.setCurrent (default)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/textw/language_text.py", line 49, in __call__
:    height = height, help = "lang")
:  File "/usr/lib/python2.7/site-packages/pyanaconda/text.py", line 533, in display_step
:    rc = win(self.screen, self.anaconda)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 387, in dispatch
:    rc = self.anaconda.intf.display_step(self.step)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/text.py", line 507, in run
:    self.anaconda.dispatch.dispatch()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 326, in run
:    self.anaconda.intf.run(self.anaconda)
:  File "/usr/sbin/anaconda", line 840, in <module>
:    anaconda.dispatch.run()
:KeyError: 'C'

environ:
:LANG=C
:LC_NUMERIC=C
:TERM=linux
:BOOT_IMAGE=vmlinuz
:XAUTHORITY=/root/.Xauthority
:GLADEPATH=/tmp/updates/:/tmp/updates/data/ui/:ui/:/usr/share/anaconda/ui/:/usr/share/python-meh/
:SHLVL=0
:PYTHONPATH=/tmp/updates
:PWD=/
:LIBUSER_CONF=/tmp/libuser.GGM70b
:LVM_SUPPRESS_FD_WARNINGS=1
:initrd=initrd.img
:MALLOC_PERTURB_=204
:GCONF_GLOBAL_LOCKS=1
:HOME=/tmp
:PIXMAPPATH=/tmp/updates/pixmaps/:/tmp/updates/:/tmp/product/pixmaps/:/tmp/product/:pixmaps/:/usr/share/anaconda/pixmaps/:/usr/share/pixmaps/:/usr/share/anaconda/:/usr/share/python-meh/:/usr/share/icons/Fedora/48x48/apps/
:PATH=/usr/bin:/bin:/sbin:/usr/sbin:/mnt/sysimage/bin:/mnt/sysimage/usr/bin:/mnt/sysimage/usr/sbin:/mnt/sysimage/sbin:/sbin:/usr/sbin
:MALLOC_CHECK_=2
Comment 1 Tao Wu 2012-03-19 01:28:15 EDT
Created attachment 571011 [details]
File: anaconda-tb-RtHtfK
Comment 2 Tao Wu 2012-03-19 01:34:06 EDT
anaconda crashed when using the text mode installer, refer to 
   
https://fedoraproject.org/wiki/QA:Testcase_Anaconda_User_Interface_Text
Comment 3 Hongqing Yang 2012-03-19 03:27:02 EDT

*** This bug has been marked as a duplicate of bug 804483 ***

Note You need to log in before you can comment on or make changes to this bug.