Bug 804483 - text install fails with traceback for 17 Beta TC2
text install fails with traceback for 17 Beta TC2
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 804499 (view as bug list)
Depends On:
Blocks: 742207 F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2012-03-18 23:34 EDT by Andre Robatino
Modified: 2012-03-23 19:32 EDT (History)
7 users (show)

See Also:
Fixed In Version: anaconda-17.14-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-23 13:45:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda traceback file for text mode install attempt from 17 Beta TC2 i386 DVD (others are almost identical) (68.82 KB, text/plain)
2012-03-18 23:34 EDT, Andre Robatino
no flags Details

  None (edit)
Description Andre Robatino 2012-03-18 23:34:56 EDT
Created attachment 570994 [details]
anaconda traceback file for text mode install attempt from 17 Beta TC2 i386 DVD (others are almost identical)

Description of problem:
Booting any 17 Beta TC2 install image (either i386 or x86_64 and either netinst or DVD) and using either the option "text" or "inst.text", immediately after specifying to use text mode instead of VNC, there is a traceback. Proposing as a Beta blocker by the Alpha criterion "The installer must be able to complete an installation using the text, graphical and VNC installation interfaces".

Version-Release number of selected component (if applicable):
whatever is in 17 Beta TC2

How reproducible:
always
Comment 1 Hongqing Yang 2012-03-19 03:27:02 EDT
*** Bug 804499 has been marked as a duplicate of this bug. ***
Comment 2 Adam Williamson 2012-03-19 17:26:31 EDT
Discussed at 2012-03-19 QA meeting, acting as a blocker review meeting. Accepted as a blocker per Alpha criterion "The installer must be able to complete an installation using the text, graphical and VNC installation interfaces".



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Will Woods 2012-03-20 15:06:52 EDT
Please try booting with:

live.updates=http://wwoods.fedorapeople.org/updates/f17b-tc2-fix-text.img

and let me know if that fixes it.
Comment 4 Andre Robatino 2012-03-20 15:26:22 EDT
It appears to fix it - I'm doing a text install for the 17 Beta TC2 i386 DVD (it's installing packages now). Unfortunately, since it doesn't use the packages on the DVD, it will take a long time, but I'll finish text installs for both i386 and x86_64 to verify that both complete successfully.
Comment 5 Andre Robatino 2012-03-20 17:07:34 EDT
Both DVD text installs successful. I also checked that both netinsts avoid the original traceback.
Comment 6 Fedora Update System 2012-03-23 01:17:32 EDT
anaconda-17.14-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.14-1.fc17
Comment 7 Fedora Update System 2012-03-23 13:09:48 EDT
Package anaconda-17.14-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-17.14-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4546/anaconda-17.14-1.fc17
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-03-23 13:45:00 EDT
anaconda-17.14-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Andre Robatino 2012-03-23 19:32:31 EDT
Confirmed fixed in RC1, in DVD installs for both i386 and x86_64.

Note You need to log in before you can comment on or make changes to this bug.