Bug 804504 - vnc interface doesn't work
vnc interface doesn't work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 804507 (view as bug list)
Depends On:
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2012-03-19 01:45 EDT by Tao Wu
Modified: 2014-10-28 19:45 EDT (History)
11 users (show)

See Also:
Fixed In Version: anaconda-17.14-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-23 13:45:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda log (779 bytes, text/x-log)
2012-03-19 01:45 EDT, Tao Wu
no flags Details

  None (edit)
Description Tao Wu 2012-03-19 01:45:06 EDT
Created attachment 571015 [details]
anaconda log

Description of problem:
Failed to boot the installer with the command-line option vnc. 

Version-Release number of selected component (if applicable):
anaconda 17.13

How reproducible:
always

Steps to Reproduce:
1.Boot the installer with the command-line option vnc
2.Watch the text messages printed out

  
Actual results:
anaconda crashed when trying to start vnc

Expected results:
anaconda starts vnc properly 

Additional info:
Comment 1 Hongqing Yang 2012-03-19 02:14:04 EDT
*** Bug 804507 has been marked as a duplicate of this bug. ***
Comment 2 Hongqing Yang 2012-03-19 02:15:00 EDT
install system with vnc, get the following error:

rpcbind: rpcbind terminating on signal. Restart with "rpcbind -w"
06:06:33 Boot argument 'vnc' is deprecated. In the future, use 'inst.vnc'.
06:06:33 Boot argument 'serial' is deprecated. In the future, use
'inst.serial'.
06:06:39 Starting VNC...                
Traceback (most recent call last):      
  File "/usr/sbin/anaconda", line 781, in <module>
    setupDisplay(anaconda, opts)
  File "/usr/sbin/anaconda", line 581, in setupDisplay
    runVNC(vncS)
  File "/usr/sbin/anaconda", line 322, in runVNC
    vncS.startServer()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/vnc.py", line 181, in
startServer
    self.initialize()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/vnc.py", line 88, in
initialize
    devname = devices[active_devs[0]].iface
KeyError: dbus.String(u'eth0', variant_level=1)
[   44.551807] audit: *NO* daemon at audit_pid=473
[   44.553219] audit: auditd disappeared
[   44.553241]
Comment 3 Kamil Páral 2012-03-21 10:45:22 EDT
Guys, please do propose this as a blocker right away, it clearly violates the criteria:

"The installer must be able to complete an installation using the text, graphical and VNC installation interfaces"
https://fedoraproject.org/wiki/Fedora_17_Alpha_Release_Criteria

Proposing now.
Comment 4 Adam Williamson 2012-03-21 11:37:02 EDT
+1 blocker, clear criterion violation.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Kevin Fenzi 2012-03-21 18:57:37 EDT
+1 blocker.
Comment 6 Jared Smith 2012-03-21 19:02:57 EDT
+1 blocker
Comment 7 Adam Williamson 2012-03-21 19:13:52 EDT
4 +1s, accepting per criterion cited in comment #3.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Bruno Wolff III 2012-03-21 22:22:06 EDT
+1 blocker
Comment 9 Fedora Update System 2012-03-23 01:17:49 EDT
anaconda-17.14-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.14-1.fc17
Comment 10 Fedora Update System 2012-03-23 13:10:04 EDT
Package anaconda-17.14-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-17.14-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4546/anaconda-17.14-1.fc17
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2012-03-23 13:45:16 EDT
anaconda-17.14-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Tao Wu 2012-03-25 22:59:09 EDT
It has been verified to solve this problem in the anaconda 17.14.

Note You need to log in before you can comment on or make changes to this bug.