Bug 804506 - anaconda does not parse 'console=ttyS0'
anaconda does not parse 'console=ttyS0'
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
AcceptedBlocker
: ReleaseNotes, Reopened
Depends On:
Blocks: 736993 F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2012-03-19 02:10 EDT by Tao Wu
Modified: 2014-10-28 19:45 EDT (History)
10 users (show)

See Also:
Fixed In Version: anaconda-17.14-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-26 09:13:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tao Wu 2012-03-19 02:10:23 EDT
Description of problem:
anaconda did not work correctly with "askmethod".

Version-Release number of selected component (if applicable):
17.13

How reproducible:
100%

Steps to Reproduce:
1.Boot the installer using any available means (netinst.iso, pxeboot images or DVD.iso) 
2.Direct anaconda to use NFS as the installation type by adding the boot command: askmethod
3.Proceed with installation 
  
Actual results:
anaconda just ignored the "askmethod" key words.

Expected results:
anaconda stopped and waited for choosing the installation repository. 

Additional info:
Comment 1 Hongqing Yang 2012-03-19 03:12:58 EDT
'serial console=ttyS0' is also not parsed.
Comment 2 Will Woods 2012-03-19 13:13:39 EDT
askmethod is deprecated and has been removed.

use an appropriate "inst.repo=XXX" argument, as suggested by the error message.

'serial' is also deprecated - it's a synonym for "console=ttyS0", so use that instead.
Comment 3 Adam Williamson 2012-03-19 19:50:46 EDT
Hongqing, can you please re-do all the TC2 tests marked as 'failing' due to this bug, with the new parameters described in comment #2? Thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Hongqing Yang 2012-03-19 23:20:26 EDT
(In reply to comment #3)
> Hongqing, can you please re-do all the TC2 tests marked as 'failing' due to
> this bug, with the new parameters described in comment #2? Thanks!
> 
> 
> 
> -- 
> Fedora Bugzappers volunteer triage team
> https://fedoraproject.org/wiki/BugZappers

It also does not work with 'console=ttyS0' which is the same with RHEL.
Comment 5 Adam Williamson 2012-03-20 01:29:20 EDT
When you say 'does not work', what happens exactly? Installation continues but does not use the serial console?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Hongqing Yang 2012-03-20 01:33:13 EDT
(In reply to comment #5)
> When you say 'does not work', what happens exactly? Installation continues but
> does not use the serial console?
> 
> 
> 
> -- 
> Fedora Bugzappers volunteer triage team
> https://fedoraproject.org/wiki/BugZappers

yes, that is. The installation continues without serial console.
Comment 7 Kamil Páral 2012-03-20 07:59:12 EDT
(In reply to comment #6)
> yes, that is. The installation continues without serial console.

Confirmed.
Comment 8 Kamil Páral 2012-03-20 08:15:18 EDT
Proposing as Beta blocker, serial console is now in Beta criteria. I know this is a dependent bug of a Beta blocker already, but just to be on the safe side.
Comment 9 Adam Williamson 2012-03-20 14:29:34 EDT
I vote +1 blocker, this is a clear infraction of "The installer must be able to complete an installation using the serial console interface".



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Adam Williamson 2012-03-21 17:50:12 EDT
Will says this ought to be fixed in current anaconda 17 branch.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Kevin Fenzi 2012-03-21 18:57:19 EDT
+1 blocker.
Comment 12 Jared Smith 2012-03-21 19:03:34 EDT
+1 blocker
Comment 13 Adam Williamson 2012-03-21 19:08:12 EDT
4 +1s (counting kamil's proposal), accepted per criterion "The installer must be able to complete an installation using the serial console interface".



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Bruno Wolff III 2012-03-21 22:23:34 EDT
+1 blocker
Comment 15 Fedora Update System 2012-03-23 01:17:38 EDT
anaconda-17.14-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.14-1.fc17
Comment 16 Fedora Update System 2012-03-23 13:09:53 EDT
Package anaconda-17.14-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-17.14-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4546/anaconda-17.14-1.fc17
then log in and leave karma (feedback).
Comment 17 Fedora Update System 2012-03-23 13:45:05 EDT
anaconda-17.14-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Tao Wu 2012-03-25 23:11:26 EDT
The "askmethod" still can not be parsed in anaconda 17.14.
Comment 19 Hongqing Yang 2012-03-26 01:02:48 EDT
(In reply to comment #18)
> The "askmethod" still can not be parsed in anaconda 17.14.

There is no 'askmethod' option, use 'inst.repo=' directly according Comments 2

The 'console=ttyS0' option is fixed.
Comment 20 Kamil Páral 2012-03-26 09:13:54 EDT
Verified and pushed, closing.
Comment 21 Adam Williamson 2012-03-27 14:53:47 EDT
We should document the removal of 'askmethod' in the release notes. Release notes folks, that's what this is for. the 'askmethod' anaconda parameter is gone in F17. Remaining methods of selecting repositories for sourcing the installer itself and/or packages to install are the 'repo=' (or 'inst.repo=', now) parameter and doing it interactively at the package installation stage of the installer.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.