This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 804509 - glusterfs mount fails with quota enabled.
glusterfs mount fails with quota enabled.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
mainline
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Kaushal
:
: 804518 804526 (view as bug list)
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-03-19 02:16 EDT by Vijaykumar Koppad
Modified: 2014-08-24 20:49 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:40:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vijaykumar Koppad 2012-03-19 02:16:48 EDT
Description of problem:Any-type of volume with quota enabled will fail to mount on glusterfs. This was not happening with previous version. 

Version-Release number of selected component (if applicable):
[1477fe376ae51ae077430aea25aa6a7a34596768]

How reproducible:always

Steps to Reproduce:
1.Create and start a volume 
2.enable quota 
3.Try to mount on glusterfs
  

Additional info:
These are the logs - 


[2012-03-19 11:34:41.895388] W [client.c:2006:client_rpc_notify] 0-doa-client-3: Cancelling the grace timer
[2012-03-19 11:34:41.895478] I [client-handshake.c:1513:select_server_supported_programs] 0-doa-client-3: Using Program GlusterFS 3git, Num (1298437), Version (330)
[2012-03-19 11:34:41.895610] I [client-handshake.c:1288:client_setvolume_cbk] 0-doa-client-1: clnt-lk-version = 1, server-lk-version = 0
[2012-03-19 11:34:41.895674] I [client-handshake.c:1314:client_setvolume_cbk] 0-doa-client-1: Connected to 192.168.1.96:24010, attached to remote volume '/root/bricks/doa/d2'.
[2012-03-19 11:34:41.895950] I [client-handshake.c:1288:client_setvolume_cbk] 0-doa-client-3: clnt-lk-version = 1, server-lk-version = 0
[2012-03-19 11:34:41.895965] I [client-handshake.c:1314:client_setvolume_cbk] 0-doa-client-3: Connected to 192.168.1.96:24012, attached to remote volume '/root/bricks/doa/d4'.
[2012-03-19 11:34:41.908170] I [fuse-bridge.c:4065:fuse_graph_setup] 0-fuse: switched to graph 0
[2012-03-19 11:34:41.908382] I [fuse-bridge.c:3342:fuse_init] 0-glusterfs-fuse: FUSE inited with protocol versions: glusterfs 7.13 kernel 7.16
[2012-03-19 11:36:37.585763] I [glusterfsd-mgmt.c:64:mgmt_cbk_spec] 0-mgmt: Volume file changed
[2012-03-19 11:36:39.408773] E [options.c:147:xlator_option_validate_sizet] 0-doa-quota: '0' in 'option timeout 0' is out of range [1 - 60]
[2012-03-19 11:36:39.408853] W [options.c:781:xl_opt_validate] 0-doa-quota: validate of timeout returned -1
[2012-03-19 11:36:39.408910] E [graph.c:281:glusterfs_graph_validate_options] 0-doa-quota: validation failed: '0' in 'option timeout 0' is out of range [1 - 60]
[2012-03-19 11:36:39.408963] E [graph.c:485:glusterfs_graph_activate] 0-graph: validate options failed
[2012-03-19 11:36:53.251327] I [fuse-bridge.c:3964:fuse_thread_proc] 0-fuse: unmounting /mnt/client1/
[2012-03-19 11:36:53.252003] W [glusterfsd.c:793:cleanup_and_exit] (-->/lib/x86_64-linux-gnu/libc.so.6(clone+0x6d) [0x7f24b2d5b59d] (-->/lib/x86_64-linux-gnu/libpthread.so.0(+0x7efc) [0x7f24b3020efc] (-->/usr/local/sbin/glusterfs(glusterfs_sigwaiter+0xe7) [0x4079ea]))) 0-: received signum (15), shutting down
[2012-03-19 11:37:11.914904] I [glusterfsd.c:1624:main] 0-/usr/local/sbin/glusterfs: Started running /usr/local/sbin/glusterfs version 3git
[2012-03-19 11:37:11.925864] E [options.c:147:xlator_option_validate_sizet] 0-doa-quota: '0' in 'option timeout 0' is out of range [1 - 60]
[2012-03-19 11:37:11.925940] W [options.c:781:xl_opt_validate] 0-doa-quota: validate of timeout returned -1
[2012-03-19 11:37:11.925975] E [graph.c:281:glusterfs_graph_validate_options] 0-doa-quota: validation failed: '0' in 'option timeout 0' is out of range [1 - 60]
[2012-03-19 11:37:11.926009] E [graph.c:485:glusterfs_graph_activate] 0-graph: validate options failed
[2012-03-19 11:37:11.926425] W [glusterfsd.c:793:cleanup_and_exit] (-->/usr/local/lib/libgfrpc.so.0(rpc_clnt_handle_reply+0x20e) [0x7f7d36bdd16d] (-->/usr/local/sbin/glusterfs(mgmt_getspec_cbk+0x35a) [0x40cfa9] (-->/usr/local/sbin/glusterfs(glusterfs_process_volfp+0x1e7) [0x408003]))) 0-: received signum (0), shutting down
[2012-03-19 11:37:11.926547] I [fuse-bridge.c:4499:fini] 0-fuse: Unmounting '/mnt/client1/'.
Comment 1 Vijaykumar Koppad 2012-03-19 03:06:58 EDT
*** Bug 804518 has been marked as a duplicate of this bug. ***
Comment 2 Kaushal 2012-03-19 05:40:28 EDT
*** Bug 804526 has been marked as a duplicate of this bug. ***
Comment 3 Anand Avati 2012-03-19 08:47:48 EDT
CHANGE: http://review.gluster.com/2976 (features/quota : Fix timeout min value) merged in master by Vijay Bellur (vijay@gluster.com)

Note You need to log in before you can comment on or make changes to this bug.