Bug 804518 - [65c6e3706f5290947179922c9e3b8f05ea6ae91c]: cannot mount fuse client when quota is enabled.
[65c6e3706f5290947179922c9e3b8f05ea6ae91c]: cannot mount fuse client when quo...
Status: CLOSED DUPLICATE of bug 804509
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
pre-release
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Raghavendra G
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 02:59 EDT by Rahul C S
Modified: 2015-12-01 11:45 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-19 03:06:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul C S 2012-03-19 02:59:35 EDT
Description of problem:
Enabled quota on the volume. Mounting fuse client fails with following client log:
[2012-03-19 12:24:16.724910] I [glusterfsd.c:1624:main] 0-/usr/local/sbin/glusterfs: Started running /usr/local/sbin/glusterfs version 3git
[2012-03-19 12:24:16.730217] E [options.c:147:xlator_option_validate_sizet] 0-vol-quota: '0' in 'option timeout 0' is out of range [1 - 60]
[2012-03-19 12:24:16.730246] W [options.c:781:xl_opt_validate] 0-vol-quota: validate of timeout returned -1
[2012-03-19 12:24:16.730260] E [graph.c:281:glusterfs_graph_validate_options] 0-vol-quota: validation failed: '0' in 'option timeout 0' is out of range [1 - 60]
[2012-03-19 12:24:16.730273] E [graph.c:485:glusterfs_graph_activate] 0-graph: validate options failed
[2012-03-19 12:24:16.730446] W [glusterfsd.c:793:cleanup_and_exit] (-->/usr/local/lib/libgfrpc.so.0(rpc_clnt_handle_reply+0x20e) [0x7fe6ce78016d] (-->/usr/local/sbin/glusterfs(mgmt_getspec_cbk+0x35a) [0x40cfa9] (-->/usr/local/sbin/glusterfs(glusterfs_process_volfp+0x1e7) [0x408003]))) 0-: received signum (0), shutting down
[2012-03-19 12:24:16.730483] I [fuse-bridge.c:4499:fini] 0-fuse: Unmounting '/data/mounts/fuse/'.


The client volfile has this under quota:
volume vol-quota
    type features/quota
    option timeout 0
    subvolumes vol-dht
end-volume

Need to put option timeout in valid range between 1-60.
Comment 1 Vijaykumar Koppad 2012-03-19 03:06:58 EDT

*** This bug has been marked as a duplicate of bug 804509 ***

Note You need to log in before you can comment on or make changes to this bug.