This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 804541 - anaconda failed to load the updates.img
anaconda failed to load the updates.img
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
AcceptedBlocker
: Reopened
Depends On:
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2012-03-19 04:14 EDT by Tao Wu
Modified: 2014-10-28 19:45 EDT (History)
11 users (show)

See Also:
Fixed In Version: anaconda-17.14-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-27 13:01:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda log (5.36 KB, text/x-log)
2012-03-19 04:14 EDT, Tao Wu
no flags Details

  None (edit)
Description Tao Wu 2012-03-19 04:14:13 EDT
Created attachment 571041 [details]
anaconda log

Description of problem:
anaconda can not load the updates.img 

Version-Release number of selected component (if applicable):
17.13

How reproducible:
100%

Steps to Reproduce:

refer to:
[1] https://fedoraproject.org/wiki/QA:Testcase_Anaconda_updates.img_via_local_media

[2] https://fedoraproject.org/wiki/QA:Testcase_Anaconda_updates.img_via_URL  
Actual results:


Expected results:


Additional info:
Comment 1 Tao Wu 2012-03-19 04:16:57 EDT
In the anaconda log, some information is:
anaconda: Network.update(): /etc/sysconfig/network-scripts/ifcfg-eth0 file not found

maybe something is wrong with the missing ifcfg-eth0 file?
Comment 2 Andre Robatino 2012-03-19 12:16:22 EDT
I see the same problem on the i386 Beta TC2 DVD, but don't find anything like your message in any of the anaconda log files. In fact, the whole pre-anaconda stage seems to be missing, for example there is no prompt for mediacheck. I checked that there was no directory "/tmp/updates" with the expected content.

BTW, these tests are labeled Beta and Alpha level, resp. In particular, the updates.img_via_URL failure appears to violate the Alpha criteria "The installer must be able to download and use an installer update image from an HTTP server". Proposing as Beta blocker.
Comment 3 Adam Williamson 2012-03-19 18:09:43 EDT
+1 blocker per criterion cited by Andre.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Will Woods 2012-03-19 21:05:12 EDT
Should be fixed in git. See these commits:

57bddf4 dracut: accept inst.updates or updates for live.updates
39af8b2 makeupdates: put files the right places

Note that this requires a slightly different file layout inside the updates.img, which makeupdates now handles correctly.
Comment 5 Bruno Wolff III 2012-03-19 22:02:46 EDT
+1 blocker
Comment 6 Kamil Páral 2012-03-20 08:27:34 EDT
+1 beta blocker
Comment 7 Josef Skladanka 2012-03-20 09:23:15 EDT
+1 blocker
Comment 8 Jared Smith 2012-03-20 14:04:18 EDT
+1 beta blocker
Comment 9 Adam Williamson 2012-03-20 14:36:23 EDT
Accepted as a blocker, with the votes above.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Fedora Update System 2012-03-23 01:18:29 EDT
anaconda-17.14-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.14-1.fc17
Comment 11 Fedora Update System 2012-03-23 13:10:33 EDT
Package anaconda-17.14-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-17.14-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4546/anaconda-17.14-1.fc17
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2012-03-23 13:45:49 EDT
anaconda-17.14-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Andre Robatino 2012-03-23 19:40:59 EDT
With RC1, it reads the file, but the directory /tmp/updates is not created as described in https://fedoraproject.org/wiki/QA:Testcase_Anaconda_updates.img_via_URL . Does the updates.img mentioned in the test need to be modified?
Comment 14 Andre Robatino 2012-03-26 17:28:34 EDT
Reopening to find what the status of this is, as no one has done either of these tests for RC1, and it looks like either failing would be a Beta blocker.
Comment 15 Brian Lane 2012-03-26 19:26:05 EDT
You will need to make sure you use an image that has either been created with anaconda's makeupdates script, or has the full /tmp/updates/ path inside the archive. The new updates system allows us to drop files anywhere on the fs, not just into /tmp/updates/
Comment 16 Andre Robatino 2012-03-26 20:02:23 EDT
I suspect that the updates.img files described in the two tests are no longer valid. I'm trying to figure out how to generate valid ones so the tests can be modified accordingly.
Comment 17 Andre Robatino 2012-03-26 20:26:04 EDT
I found the makeupdates script in the anaconda source package, but don't know how to use it. Could you look at the instructions in the two tests for creating an updates.img file (they look essentially identical) to see what's currently wrong with them? I don't understand in what sense the full /tmp/updates/ path isn't there already.
Comment 18 Adam Williamson 2012-03-27 12:10:44 EDT
Andre: https://fedoraproject.org/wiki/Anaconda/Updates#How_to_Create_an_Anaconda_Updates_Image

I'll try and test this.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 19 Adam Williamson 2012-03-27 12:26:29 EDT
So I built an updates.img to test this - http://www.happyassassin.net/extras/updates.beefy . If you do a live install it ought to change the text shown while installing to "Copying beefy live image to beefy hard drive, yo." (assuming you use English).

It doesn't seem to work. If I boot the live image with 'updates=http://www.happyassassin.net/extras/updates.beefy' then it is downloaded to /tmp/updates.img and extracted to /tmp/updates , but that tree is weirdly recursive - it winds up with a /tmp/updates/tmp/updates/pyanaconda directory. The text shown while installing doesn't change.

I built the live image by poking my anaconda checkout and then running 'scripts/makeupdates' directly, as 'make updates' fails to work, claiming there's no such target.
Comment 20 Adam Williamson 2012-03-27 12:44:48 EDT
okay, comment #19 is actually a separate issue - updates on liveinst *are* broken, but updates on non-live should work. I'll file #19 separately and verify that non-live updates work.
Comment 21 Adam Williamson 2012-03-27 13:01:23 EDT
updates on live install are https://bugzilla.redhat.com/show_bug.cgi?id=807397 . I've just confirmed that non-live updates work in Beta RC1, so we can close this.
Comment 22 Adam Williamson 2012-03-27 13:02:13 EDT
if anyone else would like to test - http://www.happyassassin.net/extras/updates.2beef will ask you "What language would you like to use during the beefy installation process?" at the first stage of install.
Comment 23 Andre Robatino 2012-03-27 16:36:25 EDT
There are 3 tests using updates.img that will have to be modified  -

https://fedoraproject.org/wiki/QA:Testcase_Anaconda_updates.img_via_URL
https://fedoraproject.org/wiki/QA:Testcase_Anaconda_updates.img_via_installation_source
https://fedoraproject.org/wiki/QA:Testcase_Anaconda_updates.img_via_local_media

No one has done the latter two yet. I did the first and can redo it after the test description is modified.
Comment 24 Hongqing Yang 2012-03-29 05:44:30 EDT
the updates.img is not copied to /tmp/updates/, but it is found in /run/initramfs/tmp/
Comment 25 Hongqing Yang 2012-03-29 06:42:57 EDT
to cover the test case
https://fedoraproject.org/wiki/QA:Testcase_Anaconda_updates.img_via_installation_source

the udpates.img is not mounted to the system, could not find it anywhere.
Comment 26 Adam Williamson 2012-04-03 18:59:07 EDT
hongqing: the final two are actually broken in current anaconda, so that's why you couldn't update the instructions. https://bugzilla.redhat.com/show_bug.cgi?id=809647 is the  bug for 'installation source', https://bugzilla.redhat.com/show_bug.cgi?id=807982 is the bug for 'local media'.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.