Bug 804592 - Rename fails during graph change
Rename fails during graph change
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: fuse (Show other bugs)
mainline
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Raghavendra G
: Triaged
: 827405 860140 (view as bug list)
Depends On:
Blocks: 848326
  Show dependency treegraph
 
Reported: 2012-03-19 07:05 EDT by Anush Shetty
Modified: 2013-07-24 13:59 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 848326 (view as bug list)
Environment:
Last Closed: 2013-07-24 13:59:15 EDT
Type: ---
Regression: ---
Mount Type: fuse
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anush Shetty 2012-03-19 07:05:21 EDT
Description of problem: Renames fails with ENOENT while the graph change was going on. This was a single export volume.


Version-Release number of selected component (if applicable): 3.3.0qa29


How reproducible: Consistently


Steps to Reproduce:
1. while true; do echo 'sdsdsd' > dot; mv dot dot2; rm -rf *; done
2. while true; do gluster volume set test2 performance.write-behind off; sleep 1; gluster volume set test2 performance.write-behind on; sleep 1; done

3.
  
Actual results:

mv: cannot move `dot' to `dot2': No such file or directory


Expected results:

Renames should continue without errors.


Additional info:

Client log:

[2012-03-19 16:31:06.223804] E [fuse-bridge.c:1511:fuse_rename_resume] 0-glusterfs-fuse: RENAME 45223 00000000-0000-0000-0000-000000000000/do
t -> 00000000-0000-0000-0000-000000000000/dot2 src resolution failed
[2012-03-19 16:31:06.229473] E [fuse-bridge.c:1329:fuse_unlink_resume] 0-glusterfs-fuse: UNLINK 1 (00000000-0000-0000-0000-000000000000/dot) 
resolution failed
[2012-03-19 16:31:06.235730] E [fuse-bridge.c:1511:fuse_rename_resume] 0-glusterfs-fuse: RENAME 45240 00000000-0000-0000-0000-000000000000/do
t -> 00000000-0000-0000-0000-000000000000/dot2 src resolution failed
[2012-03-19 16:31:06.243696] E [fuse-bridge.c:1329:fuse_unlink_resume] 0-glusterfs-fuse: UNLINK 1 (00000000-0000-0000-0000-000000000000/dot) 
resolution failed
[2012-03-19 16:31:06.249440] E [fuse-bridge.c:1511:fuse_rename_resume] 0-glusterfs-fuse: RENAME 45257 00000000-0000-0000-0000-000000000000/do
t -> 00000000-0000-0000-0000-000000000000/dot2 src resolution failed
[2012-03-19 16:31:06.252887] E [fuse-bridge.c:1329:fuse_unlink_resume] 0-glusterfs-fuse: UNLINK 1 (00000000-0000-0000-0000-000000000000/dot) 
resolution failed
[2012-03-19 16:31:06.259771] E [fuse-bridge.c:1511:fuse_rename_resume] 0-glusterfs-fuse: RENAME 45274 00000000-0000-0000-0000-000000000000/do
t -> 00000000-0000-0000-0000-000000000000/dot2 src resolution failed
[2012-03-19 16:31:06.262661] E [fuse-bridge.c:1329:fuse_unlink_resume] 0-glusterfs-fuse: UNLINK 1 (00000000-0000-0000-0000-000000000000/dot) 
resolution failed
[2012-03-19 16:31:06.271101] E [fuse-bridge.c:1511:fuse_rename_resume] 0-glusterfs-fuse: RENAME 45291 00000000-0000-0000-0000-000000000000/do
t -> 00000000-0000-0000-0000-000000000000/dot2 src resolution failed
[2012-03-19 16:31:06.273614] E [fuse-bridge.c:1329:fuse_unlink_resume] 0-glusterfs-fuse: UNLINK 1 (00000000-0000-0000-0000-000000000000/dot) 
resolution failed
[2012-03-19 16:31:06.277884] E [fuse-bridge.c:1511:fuse_rename_resume] 0-glusterfs-fuse: RENAME 45308 00000000-0000-0000-0000-000000000000/do
t -> 00000000-0000-0000-0000-000000000000/dot2 src resolution failed
[2012-03-19 16:31:06.280381] E [fuse-bridge.c:1329:fuse_unlink_resume] 0-glusterfs-fuse: UNLINK 1 (00000000-0000-0000-0000-000000000000/dot) 
resolution failed
Comment 1 Amar Tumballi 2012-03-25 03:14:16 EDT
Check if its already fixed.
Comment 2 Anush Shetty 2012-03-26 01:00:36 EDT
This issue still exists on the mainline.
Comment 3 Raghavendra G 2012-04-02 23:35:05 EDT
Patch has been sent for review at http://review.gluster.com/#change,3007
Comment 4 Anush Shetty 2012-04-23 03:07:12 EDT
With http://review.gluster.com/#change,3181 and http://review.gluster.com/#change,3181, this issue is fixed.
Comment 5 Anush Shetty 2012-04-23 03:08:09 EDT
With http://review.gluster.com/#change,3007 and  http://review.gluster.com/#change,3181 I meant.
Comment 6 Anand Avati 2012-05-08 18:34:57 EDT
CHANGE: http://review.gluster.com/3007 (fuse-resolve: consider cases where an entry should be resolved even when parent belongs to active itable.) merged in master by Anand Avati (avati@redhat.com)
Comment 7 Anand Avati 2012-05-15 20:09:15 EDT
CHANGE: http://review.gluster.com/3181 (fuse-resolve: Attempt fd-migration in resolver, if migration was never attempted.) merged in master by Anand Avati (avati@redhat.com)
Comment 8 Vijay Bellur 2012-05-18 09:12:23 EDT
Addressing this post 3.3.0.
Comment 9 Raghavendra G 2012-08-29 05:17:15 EDT
*** Bug 827405 has been marked as a duplicate of this bug. ***
Comment 10 Amar Tumballi 2012-10-11 05:40:16 EDT
*** Bug 860140 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.