Bug 860140 - Error when renaming a file, and while enabling/disabling performance translators
Error when renaming a file, and while enabling/disabling performance translators
Status: CLOSED DUPLICATE of bug 804592
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Raghavendra G
Sudhir D
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 01:19 EDT by SATHEESARAN
Modified: 2012-10-11 05:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-11 05:40:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description SATHEESARAN 2012-09-25 01:19:15 EDT
Description of problem:
While renaming the file continuously(from 'oldname' to 'newname' and vice versa), and disabling any of performance translators, throws errors[ mv: cannot move 'oldfile' to 'newfile' :No such file or directory  OR 'oldfile' and 'newfile' are the same file]

Version-Release number of selected component (if applicable):
RHS 2.0

How reproducible:
Consistent

Steps to Reproduce:
1. Rename the file continuously in a loop [mv 'oldfile' 'newfile']
2. Try to disable/enable performance translators(stat-prefetch,quick-read,io-cache,read-ahead,write-behind) through volume set option

  
Actual results:
1. Getting errors while renaming a file[mv: cannot move 'oldfile' to 'newfile' :No such file or directory  OR 'oldfile' and 'newfile' are the same file]

NOTE: this error was transient, after sometime renaming continues without error

Expected results:
There should not be any errors in renaming a files

Additional info:
Comment 2 Amar Tumballi 2012-09-26 01:07:33 EDT
Du, is it same as the rename issue with fuse resolve? (the parents' graph differ).
Comment 3 Amar Tumballi 2012-10-11 05:40:16 EDT
same as bug 804592

*** This bug has been marked as a duplicate of bug 804592 ***

Note You need to log in before you can comment on or make changes to this bug.