Bug 804618 - Host installation fails due to module import error
Host installation fails due to module import error
Status: CLOSED NEXTRELEASE
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Federico Simoncelli
yeylon@redhat.com
: Regression
: 806623 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 08:54 EDT by Rami Vaknin
Modified: 2016-04-18 02:44 EDT (History)
15 users (show)

See Also:
Fixed In Version: v4.9.6-1-31-gf02e202
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 15:15:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rami Vaknin 2012-03-19 08:54:48 EDT
I've installed two hosts - one of the is RHEL6.3, the second is Fedora16 - both of them using vdsm-bootstrap-4.9.6-0.27.giteaebe06.el6.noarch, host installation failed on both of them with the following error:

Mon, 19 Mar 2012 11:55:57 DEBUG    <BSTRAP component='VDS PACKAGES' status='OK' result='libselinux-python' message='libselinux-python-2.0.94-5.3.el6.x86_64 '/>
Mon, 19 Mar 2012 11:55:57 ERROR    
Traceback (most recent call last):
  File "/tmp/vds_bootstrap_b7b215a5-3f75-4c39-b3a9-09f8ffb71636.py", line 571, in createConf
    self._makeConfig()
  File "/tmp/vds_bootstrap_b7b215a5-3f75-4c39-b3a9-09f8ffb71636.py", line 534, in _makeConfig
    from vdsm.config import config
ImportError: No module named vdsm.config
Mon, 19 Mar 2012 11:55:57 DEBUG    <BSTRAP component='CreateConf' status='FAIL' message='Basic configuration failed to import default values'/>
Mon, 19 Mar 2012 11:55:57 ERROR    createConf failed
Mon, 19 Mar 2012 11:55:57 DEBUG    <BSTRAP component='RHEV_INSTALL' status='FAIL'/>
Comment 1 Federico Simoncelli 2012-03-20 06:25:31 EDT
Initial patch posted upstream:

commit 1c6c053b3d9faee64cd5596001d751f52537b2b4
Author: Federico Simoncelli <fsimonce@redhat.com>
Date:   Tue Mar 20 10:21:08 2012 +0000

    BZ#804618 Add legacy imports to bootstrap
    
    Change-Id: I4cc76667e6a6b59c6a169ba2c4cd22013e46900c

http://gerrit.ovirt.org/2951
Comment 2 Dan Kenigsberg 2012-04-18 15:15:43 EDT
*** Bug 806623 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.