Bug 806623 - rhevm registration fails with rhev-h
rhevm registration fails with rhev-h
Status: CLOSED DUPLICATE of bug 804618
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.2
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Dan Kenigsberg
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-25 09:39 EDT by Mike Burns
Modified: 2016-04-18 02:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 15:15:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Burns 2012-03-25 09:39:43 EDT
Description of problem:
Trying to register to RHEV-M using RHEV-H fails

makeBridge failed to find vdsm modules

Version-Release number of selected component (if applicable):
vdsm-4.9.6-4.el6
rhevm-3.0.2_0001-2.el6.x86_64
Red Hat Enterprise Virtualization Hypervisor release 6.3 (20120307.2.auto475)

How reproducible:
Always

Steps to Reproduce:
1.Install rhevh
2.register to rhevh
3.
  
Actual results:
Fails

Expected results:
Registers successfully

Additional info:
vdsm-reg log

MainThread::DEBUG::2012-03-25 13:37:18,049::vdsm-reg-setup::270::vdsRegistrator::Total retry count: 2, waited: 10 seconds.
MainThread::DEBUG::2012-03-25 13:37:18,050::vdsm-reg-setup::37::root::__init__ begin.
MainThread::DEBUG::2012-03-25 13:37:18,050::deployUtil::299::root::_getMGTIface: read host name: rhevm30-2.virt.bos.redhat.com
MainThread::DEBUG::2012-03-25 13:37:18,051::deployUtil::306::root::_getMGTIface: using host name rhevm30-2.virt.bos.redhat.com strIP= 10.16.72.91
MainThread::DEBUG::2012-03-25 13:37:18,051::deployUtil::312::root::_getMGTIface IP=10.16.72.91 strIface=breth4
MainThread::DEBUG::2012-03-25 13:37:18,062::deployUtil::331::root::getMGTIP: Host parsed interfaces:
{'bond4': {'hwaddr': '00:00:00:00:00:00', 'netmask': '', 'addr': ''}, 'bond0': {'hwaddr': '00:00:00:00:00:00', 'netmask': '', 'addr': ''}, 'bond1': {'hwaddr': '00:00:00:00:00:00', 'netmask': '', 'addr': ''}, 'bond2': {'hwaddr': '00:00:00:00:00:00', 'netmask': '', 'addr': ''}, 'bond3': {'hwaddr': '00:00:00:00:00:00', 'netmask': '', 'addr': ''}, 'lo': {'hwaddr': '', 'netmask': '255.0.0.0', 'addr': '127.0.0.1'}, 'breth4': {'hwaddr': '00:21:5E:73:B4:C8', 'netmask': '255.255.252.0', 'addr': '10.16.72.118'}, 'eth5': {'hwaddr': '00:21:5E:73:B4:CA', 'netmask': '', 'addr': ''}, 'eth4': {'hwaddr': '00:21:5E:73:B4:C8', 'netmask': '', 'addr': ''}, 'eth3': {'hwaddr': '00:15:17:A6:58:B7', 'netmask': '', 'addr': ''}, 'eth2': {'hwaddr': '00:15:17:A6:58:B6', 'netmask': '', 'addr': ''}, 'eth1': {'hwaddr': '00:15:17:A6:58:B5', 'netmask': '', 'addr': ''}, 'eth0': {'hwaddr': '00:15:17:A6:58:B4', 'netmask': '', 'addr': ''}}

MainThread::DEBUG::2012-03-25 13:37:18,062::deployUtil::336::root::getMGTIP: Host MGT IP=10.16.72.118
MainThread::DEBUG::2012-03-25 13:37:18,063::deployUtil::103::root::['/usr/sbin/dmidecode', '-s', 'system-uuid']
MainThread::DEBUG::2012-03-25 13:37:18,072::deployUtil::107::root::403F67EA-8A82-B601-ADE7-00215E73B4C8

MainThread::DEBUG::2012-03-25 13:37:18,072::deployUtil::108::root::
MainThread::DEBUG::2012-03-25 13:37:18,073::deployUtil::277::root::getHostID: 403F67EA-8A82-B601-ADE7-00215E73B4C8_00:15:17:a6:58:b4
MainThread::DEBUG::2012-03-25 13:37:18,074::vdsm-reg-setup::63::root::Setup::__init__ vars: {'vdcRegPort': '54321', 'ovirtUID': '403F67EA-8A82-B601-ADE7-00215E73B4C8_00:15:17:a6:58:b4', 'ovirtName': 'virtlab103.virt.bos.redhat.com', 'fInitOK': True, 'registered': False, 'ovirtURL': '10.16.72.118', 'vdcName': 'rhevm30-2.virt.bos.redhat.com', 'vdcPORT': '8080', 'VDCTime': None, 'ticket': '', 'vdcURI': '/OvirtEngineWeb/register', 'vdsmDir': '/usr/share/vdsm', 'vdcURL': '10.16.72.91'}
MainThread::DEBUG::2012-03-25 13:37:18,074::vdsm-reg-setup::66::root::validate start
MainThread::DEBUG::2012-03-25 13:37:18,074::vdsm-reg-setup::73::root::validate end. return: True
MainThread::DEBUG::2012-03-25 13:37:18,074::vdsm-reg-setup::180::root::execute start.
MainThread::DEBUG::2012-03-25 13:37:18,075::deployUtil::349::root::Bridge rhevm not found, need to create it.
MainThread::DEBUG::2012-03-25 13:37:18,075::vdsm-reg-setup::80::root::renameBridge begin.
MainThread::DEBUG::2012-03-25 13:37:18,075::deployUtil::818::root::makeBridge begin.
MainThread::ERROR::2012-03-25 13:37:18,075::deployUtil::823::root::makeBridge Failed to find vdsm modules!
MainThread::ERROR::2012-03-25 13:37:18,076::vdsm-reg-setup::86::root::renameBridge Failed to rename existing bridge!
MainThread::DEBUG::2012-03-25 13:37:18,076::vdsm-reg-setup::110::root::renameBridge return.
MainThread::DEBUG::2012-03-25 13:37:18,076::vdsm-reg-setup::187::root::execute: after renameBridge: False
MainThread::DEBUG::2012-03-25 13:37:18,076::vdsm-reg-setup::206::root::Registration status: False
Comment 1 Dan Kenigsberg 2012-04-18 15:15:43 EDT
MainThread::ERROR::2012-03-25 13:37:18,075::deployUtil::823::root::makeBridge
Failed to find vdsm modules!

this specific issue has been solved, but rhev-h still does not register :-(

*** This bug has been marked as a duplicate of bug 804618 ***

Note You need to log in before you can comment on or make changes to this bug.