Bug 804660 - segfault in _clutter_actor_finish_queue_redraw
segfault in _clutter_actor_finish_queue_redraw
Status: CLOSED DUPLICATE of bug 791130
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 10:24 EDT by Tom London
Modified: 2012-04-03 10:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-03 10:51:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2012-03-19 10:24:51 EDT
Description of problem:

Got segfault/coredump from gnome shell when I moved cursor to upper left corner. Stack backtrace below.

Had just completed 'yum update' that updated the following packages:

Installed:
  kernel.x86_64 0:3.3.0-2.fc18            kernel-devel.x86_64 0:3.3.0-2.fc18    
  redhat-lsb-core.x86_64 0:4.1-1.fc18    

Dependency Installed:
  foomatic-filters.x86_64 0:4.0.8-8.fc18                                        
  redhat-lsb-cxx.x86_64 0:4.1-1.fc18                                            
  redhat-lsb-desktop.x86_64 0:4.1-1.fc18                                        
  redhat-lsb-languages.x86_64 0:4.1-1.fc18                                      
  redhat-lsb-printing.x86_64 0:4.1-1.fc18                                       
  redhat-lsb-submod-multimedia.x86_64 0:4.1-1.fc18                              
  redhat-lsb-submod-security.x86_64 0:4.1-1.fc18                                

Updated:
  device-mapper.x86_64 0:1.02.74-5.fc18                                         
  device-mapper-devel.x86_64 0:1.02.74-5.fc18                                   
  device-mapper-event.x86_64 0:1.02.74-5.fc18                                   
  device-mapper-event-devel.x86_64 0:1.02.74-5.fc18                             
  device-mapper-event-libs.x86_64 0:1.02.74-5.fc18                              
  device-mapper-libs.x86_64 0:1.02.74-5.fc18                                    
  dvd+rw-tools.x86_64 0:7.1-7.fc18                                              
  emacs.x86_64 1:24.0.94-3.fc18                                                 
  emacs-common.x86_64 1:24.0.94-3.fc18                                          
  emacs-filesystem.x86_64 1:24.0.94-3.fc18                                      
  evolution.x86_64 0:3.3.92-1.fc18                                              
  evolution-data-server.x86_64 0:3.3.92-1.fc18                                  
  evolution-data-server-doc.noarch 0:3.3.92-1.fc18                              
  evolution-help.noarch 0:3.3.92-1.fc18                                         
  evolution-pst.x86_64 0:3.3.92-1.fc18                                          
  gpxe-roms-qemu.noarch 0:1.0.1-6.fc18                                          
  gsettings-desktop-schemas.x86_64 0:3.3.92-1.fc18                              
  gsettings-desktop-schemas-devel.x86_64 0:3.3.92-1.fc18                        
  gtkhtml3.x86_64 0:4.3.92-1.fc18                                               
  im-chooser.x86_64 0:1.5.2.1-1.fc18                                            
  im-chooser-common.x86_64 0:1.5.2.1-1.fc18                                     
  im-chooser-xfce.x86_64 0:1.5.2.1-1.fc18                                       
  imsettings.x86_64 0:1.2.8.1-1.fc18                                            
  imsettings-gnome.x86_64 0:1.2.8.1-1.fc18                                      
  imsettings-libs.x86_64 0:1.2.8.1-1.fc18                                       
  javapackages-tools.noarch 0:0.3.1-1.fc18                                      
  kde-settings.noarch 0:4.8-7.fc18                                              
  kernel-headers.x86_64 0:3.3.0-2.fc18                                          
  kernel-tools.x86_64 0:3.3.0-2.fc18                                            
  libgxps.x86_64 0:0.2.2-1.fc18                                                 
  lvm2.x86_64 0:2.02.95-5.fc18                                                  
  lvm2-libs.x86_64 0:2.02.95-5.fc18                                             
  perl-Archive-Zip.noarch 0:1.30-8.fc18                                         
  perl-Parse-RecDescent.noarch 0:1.967009-1.fc18                                
  perl-Pod-Perldoc.noarch 0:3.17-1.fc18                                         
  perl-Socket.x86_64 0:2.000-2.fc18                                             
  perl-XML-LibXML.x86_64 1:1.96-1.fc18                                          
  qemu-common.x86_64 2:1.0-8.fc18                                               
  qemu-img.x86_64 2:1.0-8.fc18                                                  
  qemu-kvm.x86_64 2:1.0-8.fc18                                                  
  qemu-kvm-tools.x86_64 2:1.0-8.fc18                                            
  qemu-system-x86.x86_64 2:1.0-8.fc18                                           

Dependency Updated:
  redhat-lsb.x86_64 0:4.1-1.fc18                                                

Replaced:
  redhat-lsb.x86_64 0:4.0-11.fc17                                               



Core was generated by `/usr/bin/gnome-shell'.
Program terminated with signal 11, Segmentation fault.
#0  _clutter_actor_finish_queue_redraw (self=0x30591, clip=0x0)
    at ./clutter-actor.c:6541
6541	  ClutterActorPrivate *priv = self->priv;
Missing separate debuginfos, use: debuginfo-install evolution-data-server-3.3.92-1.fc18.x86_64 ibus-gtk3-1.4.99.20120317-1.fc18.x86_64 ibus-libs-1.4.99.20120317-1.fc18.x86_64 nss-util-3.13.3-2.fc17.x86_64 polkit-0.104-6.fc17.x86_64
(gdb) set pagination off
(gdb) bt full
#0  _clutter_actor_finish_queue_redraw (self=0x30591, clip=0x0) at ./clutter-actor.c:6541
        priv = <optimized out>
        pv = <optimized out>
        clipped = <optimized out>
#1  0x00000036a72958ae in _clutter_stage_maybe_finish_queue_redraws (stage=<optimized out>) at ./clutter-stage.c:4094
        entry = 0x34184a1
        clip = <optimized out>
        l = 0xb4feae0 = {0x34184a1, 0x3418120, 0x3418520, 0x3418220, 0x34186a0, 0x3418720, 0x3418420, 0x34183a0, 0x2d46aa0, 0x2d46c20, 0x2d46d20, 0x6504120, 0x65040a0, 0x6504520, 0x65044a0, 0x65046a0, 0x65045a0, 0x6504620, 0x6504020, 0x6504220, 0x6504320, 0x65042a0, 0x65041a0, 0x65043a0, 0x3418020, 0x325c190, 0x325c410, 0x31af730, 0x31af430, 0x31af1b0, 0x3418320, 0x3484b80, 0x3484c80, 0x3484c00, 0x3450a40, 0x3484880, 0x3484800, 0x3484e00, 0x31af130, 0x31af530, 0x31af3b0, 0x31af0b0, 0x2be4c80, 0x2be4f00, 0x3450dc0, 0x325c610, 0x34185a0, 0x3450cc0, 0x34a89c0, 0x2d46a20, 0x34a8ec0, 0x6504420, 0x3450b40, 0x325c710, 0x2d46ba0, 0x2d469a0, 0x325c210, 0x33722c0, 0x3484e80, 0x6504720, 0x31e0e00, 0x325c690, 0x325c090, 0x2d46ca0, 0x3372540, 0x34a8dc0}
        stolen_list = 0x34cfae0 = {0x34d72c0, 0x34d7240, 0x34d71c0, 0x34d7140, 0x34d70c0, 0x34d7040, 0x34c3710, 0x34c3690, 0x34c3610, 0x34c3590, 0x34c3510, 0x34c3490, 0x34c3410, 0x34c3390, 0x34c3310, 0x34c3290, 0x34c3210, 0x34c3190, 0x34c3110, 0x34c3090, 0x34c3010, 0x34d1f00, 0x34d1e80, 0x34d1e00, 0x34d1d80, 0x34d1d00, 0x34d1c80, 0x34d1c00, 0x34d1b80, 0x34d1b00, 0x34d1a80, 0x34d1a00, 0x34d1980, 0x34d1900, 0x34d1880, 0x34d1800, 0x34d1730, 0x34d16b0, 0x34d1630, 0x34d15b0, 0x34d1530, 0x34d14b0, 0x34d1430, 0x34d13b0, 0x34d1330, 0x34d12b0, 0x34d1230, 0x34d11b0, 0x34d1130, 0x34d10b0, 0x34d1030, 0x347cf20, 0x347cea0, 0x347ce20, 0x347cda0, 0x347cd20, 0x347cca0, 0x347cc20, 0x347cba0, 0x347cb20, 0x347caa0, 0x347ca20, 0x347c9a0, 0x347c920, 0x347c8a0, 0x347c820, 0x3484d00, 0x3484d80, 0x34a8c40, 0x34a8e40, 0x34a8cc0, 0x34a8d40, 0x34a8f40, 0x34a8840, 0x325c110, 0x325c510, 0x325c390, 0x325c010, 0x325c310, 0x325c590, 0x325c490, 0x3372140, 0x3372040, 0x3372740, 0x33724c0, 0x33726c0, 0x33723c0, 0x33725c0, 0x3372640, 0x33721c0, 0x3372240, 0x3372440, 0x3372340, 0x31e0f00, 0x31e0b00, 0x31e0800, 0x31e0880, 0x31e0980, 0x31e0e80, 0x31e0a00, 0x31e0900, 0x31e0b80, 0x31e0c00, 0x31e0a80, 0x31e0d00, 0x31e0d80, 0x3450e40, 0x3450840, 0x34509c0, 0x3450c40, 0x3450f40, 0x3450bc0, 0x34508c0, 0x3450940, 0x3450ac0, 0x34182a0, 0x34180a0, 0x34184a1, 0x3418120, 0x3418520, 0x3418220, 0x34186a0, 0x3418720, 0x3418420, 0x34183a0, 0x2d46aa0, 0x2d46c20, 0x2d46d20, 0x6504120, 0x65040a0, 0x6504520, 0x65044a0, 0x65046a0, 0x65045a0, 0x6504620, 0x6504020, 0x6504220, 0x6504320, 0x65042a0, 0x65041a0, 0x65043a0, 0x3418020, 0x325c190, 0x325c410, 0x31af730, 0x31af430, 0x31af1b0, 0x3418320, 0x3484b80, 0x3484c80, 0x3484c00, 0x3450a40, 0x3484880, 0x3484800, 0x3484e00, 0x31af130, 0x31af530, 0x31af3b0, 0x31af0b0, 0x2be4c80, 0x2be4f00, 0x3450dc0, 0x325c610, 0x34185a0, 0x3450cc0, 0x34a89c0, 0x2d46a20, 0x34a8ec0, 0x6504420, 0x3450b40, 0x325c710, 0x2d46ba0, 0x2d469a0, 0x325c210, 0x33722c0, 0x3484e80, 0x6504720, 0x31e0e00, 0x325c690, 0x325c090, 0x2d46ca0, 0x3372540, 0x34a8dc0}
#2  _clutter_stage_do_update (stage=0x1d077e0 [ClutterStage]) at ./clutter-stage.c:1217
        priv = 0x1d07b00
#3  0x00000036a727f6b5 in clutter_clock_dispatch (source=source@entry=0x1d07fb0, callback=<optimized out>, user_data=<optimized out>) at ./clutter-master-clock.c:398
        clock_source = 0x1d07fb0
        master_clock = 0x2b21480 [ClutterMasterClock]
        stage_manager = <optimized out>
        stages_updated = <optimized out>
        stages = 0x942e610 = {0x1d077e0}
        l = 0x942e610 = {0x1d077e0}
#4  0x0000003ed3c4773c in g_main_dispatch (context=0x1bd3a10) at gmain.c:2510
        dispatch = 0x36a727f5e0 <clutter_clock_dispatch>
        was_in_call = 0
        user_data = 0x0
        callback = 0
        cb_funcs = 0x0
        cb_data = 0x0
        current_source_link = {data = 0x1d07fb0, next = 0x0}
        need_destroy = <optimized out>
        source = 0x1d07fb0
        current = 0x2a01330
        i = <optimized out>
#5  g_main_context_dispatch (context=context@entry=0x1bd3a10) at gmain.c:3047
No locals.
#6  0x0000003ed3c47b58 in g_main_context_iterate (context=0x1bd3a10, block=block@entry=1, dispatch=dispatch@entry=1, self=<error reading variable: Unhandled dwarf expression opcode 0xfa>) at gmain.c:3118
        max_priority = 150
        timeout = 0
        some_ready = 1
        nfds = <optimized out>
        allocated_nfds = <optimized out>
        fds = 0x2dbeac0
#7  0x0000003ed3c47f42 in g_main_loop_run (loop=0x1bd45e0) at gmain.c:3312
        __PRETTY_FUNCTION__ = "g_main_loop_run"
#8  0x00000036a6e546a7 in meta_run () at core/main.c:555
        log_domains = {0x0, 0x36a6e9c0ba "mutter", 0x36a6e9b41d "Gtk", 0x36a6e9b421 "Gdk", 0x36a6e9b425 "GLib", 0x36a6e9b42a "Pango", 0x36a6e9b430 "GLib-GObject", 0x36a6e9b43d "GThread"}
        i = <optimized out>
#9  0x0000000000401cc6 in main (argc=1, argv=0x7fff1cd1b7d8) at main.c:352
        ctx = <optimized out>
        error = 0x0
        session_type = <optimized out>
        ecode = <optimized out>
        sender = 0x7f8424005b20 [TpDebugSender]
(gdb) 


Version-Release number of selected component (if applicable):
gnome-shell-3.3.90-2.fc17.x86_64

How reproducible:
Don't know

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Owen Taylor 2012-04-03 10:51:38 EDT

*** This bug has been marked as a duplicate of bug 791130 ***

Note You need to log in before you can comment on or make changes to this bug.