Bug 804880 - rwhod is killed by systemd
rwhod is killed by systemd
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rwho (Show other bugs)
16
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Honza Horak
Fedora Extras Quality Assurance
:
: 815590 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-20 00:18 EDT by Ian Donaldson
Modified: 2012-04-24 10:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-22 09:27:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Donaldson 2012-03-20 00:18:05 EDT
Description of problem:

rwhod won't stay up for more than about 2 minutes, then systemd kills it

Version-Release number of selected component (if applicable):

rwho-0.17-36.fc16.i686


How reproducible:

100%

Steps to Reproduce:
1. systemctl start rwhod.service
2. note this doesn't return for 2 minutes; note rwhod runs for 2 minutes
3. note rwhod is no longer running after 2 minutes
  
Actual results:

rwhod not running


Expected results:

rwhod running

Additional info:

 /lib/systemd/system/rwhod.service has been configured with the
PIDFile=/var/run/rwhod.pid  parameter, telling systemd to expect a pid
file when rwhod is happy.

However rwhod never writes a pid file, so systemd kills it after 2 minutes.

In prior Fedora releases, the /etc/init.d/rwhod script did a 'touch /var/run/rwhod.pid' for completeness.

The fix is to remove the PIDFile arg from /lib/systemd/system/rwhod.service,
or to modify rwhod source to get it to write a pid file.
Comment 1 Honza Horak 2012-03-22 09:27:23 EDT
This bug has been fixed together with bug #799246 and a new rwho-0.17-39.fc16 is already in F16.

Please, try the new build also available here:
https://admin.fedoraproject.org/updates/FEDORA-2012-3344/rwho-0.17-39.fc16
Comment 2 Ian Donaldson 2012-03-22 18:59:07 EDT
Tried new version; starts ok.  Thanks.
Comment 3 Honza Horak 2012-04-24 10:49:26 EDT
*** Bug 815590 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.