Bug 815590 - rwhod fails to start from systemd
rwhod fails to start from systemd
Status: CLOSED DUPLICATE of bug 804880
Product: Fedora
Classification: Fedora
Component: rwho (Show other bugs)
16
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Honza Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 22:16 EDT by Ian Dall
Modified: 2012-04-24 10:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-24 10:49:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Dall 2012-04-23 22:16:00 EDT
Description of problem:

"systemctl start rwhod.service" fails 

Version-Release number of selected component (if applicable):
rwho-0.17-36.fc16.i686

How reproducible:
Always

Steps to Reproduce:
1.systemctl start rwhod.service 
2.systemctl status rwhod.service
3.
  
Actual results:

rwhod.service - Remote Machine Logged In User Lister
	  Loaded: loaded (/lib/systemd/system/rwhod.service; enabled)
	  Active: failed since Tue, 24 Apr 2012 11:29:47 +0930; 10s ago
	 Process: 13653 ExecStart=/usr/sbin/rwhod (code=exited, Status=0/SUCCESS)
	  CGroup: name=systemd:/system/rwhod.service


Expected results:
rwhod should start


Additional info:

This seems to be due to the PIDFile=/var/run/rwhod.pid line in /lib/systemd/system/rwhod.service. The rwhod evidently doesn't write to a PIDFile (or at least not the one specified). If the PIDFile specification is deleted, systemctl seems to be able to guess the pid OK and everythign is good. Alternatively, rwhod could be modified to write its pid to a file.
Comment 1 Honza Horak 2012-04-24 10:49:26 EDT
This is already solved by the following update:
https://admin.fedoraproject.org/updates/FEDORA-2012-3344/rwho-0.17-39.fc16

Please, update the package to the current build rwho-0.17-39.fc16 using the link above.

*** This bug has been marked as a duplicate of bug 804880 ***

Note You need to log in before you can comment on or make changes to this bug.