Bug 80496 - up2date registration failures mailed every day
up2date registration failures mailed every day
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: logwatch (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
: 99438 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-27 01:25 EST by Alexandre Oliva
Modified: 2007-04-18 12:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-07 14:27:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
modification of logwatch.spec to include the missing scripts (2.22 KB, patch)
2003-03-15 09:14 EST, Radu Greab
no flags Details | Diff
Improved spec file patch to get all scripts/logfiles/* subdirectories (1.92 KB, patch)
2003-10-22 17:19 EDT, Gilles Detillieux
no flags Details | Diff

  None (edit)
Description Alexandre Oliva 2002-12-27 01:25:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
I tried to register my machine a few times before the Phoebe channel was set up
in RHN.  Since then, I've got messages in the mail every day, from LogWatch,
containing the same errors.  I suppose these will only go away when logrotate
moves them to a separate file, if ever...

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.Try to register a machine in an invalid channel
2.Read LogWatch e-mail every day


Actual Results:  Every day, it will say something like:
 ################### LogWatch 4.0.3 (10/14/02) #################### 
       Processing Initiated: Fri Dec 27 04:02:02 2002
       Date Range Processed: yesterday
[...]
 --------------------- up2date Begin ------------------------ 


**Unmatched Entries**
[Mon Dec 23 15:46:38 2002] up2date Error communicating with server. The message was:

Error Message:
    Your account does not have access to any channels matching
(release='8.0.92', arch='i686-redhat-linux')
Error Class Code: 19
Error Class Info: 
     Architecture and OS version combination is not supported.
     If you have a registration number, please register with it
     first at http://www.redhat.com/now and then try again.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please submit a bug report to rhn-help@redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.
[...]
 ---------------------- up2date End ------------------------- 


 ###################### LogWatch End ######################### 


Expected Results:  These messages should have been included only in the e-mail I
got on Dec 24's morning.

Additional info:
Comment 1 Elliot Lee 2003-02-19 18:36:24 EST
Can you try running 'chkconfig --level 135 rhnsd off' and seeing if that is the
actual cause?
Comment 2 Alexandre Oliva 2003-02-19 23:27:02 EST
It isn't the cause.  rhnsd has been enabled since I installed the new beta, and
it hasn't generated any such messages.  Now, that I've just tried to register
the machines, hoping a RHN channel would have been set up, I get the messages
from logwatch.
Comment 3 Radu Greab 2003-03-15 09:06:02 EST
logwatch-4.3.1-2 does not contain the scripts that should go inside the
/etc/log.d/scripts/logfiles/{autorpm,cron,up2date} directories. One job of these
scripts is to apply to the logs a filter based on the date requested. The rpm
should be updated to include the scripts and the this problem would be resolved.

I have the same problem with the cron section of logwatch reports.
Comment 4 Radu Greab 2003-03-15 09:14:11 EST
Created attachment 90609 [details]
modification of logwatch.spec to include the missing scripts
Comment 5 Elliot Lee 2003-04-11 14:18:18 EDT
logwatch 4.3.2 + your patch will be in rawhide, thanks.
Comment 6 Gilles Detillieux 2003-10-22 17:19:30 EDT
Created attachment 95408 [details]
Improved spec file patch to get all scripts/logfiles/* subdirectories

The problem with the previous patch is the directory names are still hardcoded,
even though the list now includes all current scripts/logfiles/*
subdirectories. This will break if any new subdirectories are added in future
source tarballs. A better approach is to borrow the loop that Kirk Bauer uses
in his spec file, and use wildcards in the %files section. See my improved
patch.
Comment 7 Elliot Lee 2004-07-07 14:27:04 EDT
Thanks Gilles - that was just what was needed! Patch added after a
long delay.
Comment 8 Elliot Lee 2004-08-20 14:53:31 EDT
*** Bug 99438 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.