This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 805122 - Sorting algorithm for sync history does not return correct recent status
Sorting algorithm for sync history does not return correct recent status
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Eric Helms
Og Maciel
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-20 11:10 EDT by Og Maciel
Modified: 2014-09-18 11:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-22 14:31:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot showing the error and number of notifications (69.15 KB, image/png)
2012-03-20 11:10 EDT, Og Maciel
no flags Details

  None (edit)
Description Og Maciel 2012-03-20 11:10:01 EDT
Created attachment 571437 [details]
Screenshot showing the error and number of notifications

Description of problem:

Visiting the Syn Management page for an Org gives me undefined method `<=>' for nil:NilClass and a 500 Internal Server error. As per discussion with Ivan, this is a regression of https://bugzilla.redhat.com/show_bug.cgi?id=798376.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create  new repo with some bigger amount of packages, e.g. http://repos.fedorapeople.org/repos/katello/katello/fedora-16/x86_64/ should be good
2. set sync plan for it
3. synchronize it manually after that
4. optionally, refresh the sync status page while synchronizing
  
Actual results:

Subsequent visits to the Sync Management page return a *undefined method `<=>' for nil:NilClass* notification. It also generates hundreds of notification messages.

Expected results:


Additional info:
Comment 4 Og Maciel 2012-03-23 10:50:27 EDT
Verified:
* candlepin-0.5.26-1.el6.noarch
* candlepin-tomcat6-0.5.26-1.el6.noarch
* katello-0.1.306-1.el6.noarch
* katello-all-0.1.306-1.el6.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.0.4-1.el6.noarch
* katello-cli-0.1.107-1.el6.noarch
* katello-cli-common-0.1.107-1.el6.noarch
* katello-common-0.1.306-1.el6.noarch
* katello-configure-0.1.104-1.el6.noarch
* katello-glue-candlepin-0.1.306-1.el6.noarch
* katello-glue-foreman-0.1.306-1.el6.noarch
* katello-glue-pulp-0.1.306-1.el6.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-0.1.8-1.el6.noarch
* pulp-1.0.0-4.el6.noarch
* pulp-common-1.0.0-4.el6.noarch
* pulp-selinux-server-1.0.0-4.el6.noarch
Comment 6 Anton Arapov 2012-09-07 03:37:43 EDT
*** Bug 835422 has been marked as a duplicate of this bug. ***
Comment 7 Mike McCune 2013-08-16 14:05:02 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.