Bug 805308 - kded4 crashes on resuming
kded4 crashes on resuming
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bluedevil (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Reznik
Fedora Extras Quality Assurance
:
: 794955 806075 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-20 16:32 EDT by Stefan Becker
Modified: 2012-05-14 14:02 EDT (History)
11 users (show)

See Also:
Fixed In Version: bluedevil-1.3-0.3.rc1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-14 14:01:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
information saved from kcrash dialog (5.39 KB, text/plain)
2012-03-20 17:04 EDT, Stefan Becker
no flags Details

  None (edit)
Description Stefan Becker 2012-03-20 16:32:29 EDT
Description of problem:

kded4 crashes with segmentation fault after resume. I have never seen this crash when the system was still running on F16.

Version-Release number of selected component (if applicable):
kdelibs-4.8.1-2.fc17.x86_64

How reproducible: 100% of the resumes after first KDE login or if I restart kded4 without --nocrashhandler option.


Steps to Reproduce:
1. login to KDE session
2. put system to suspend-to-ram
3. resume
  
Actual results: KDE crash dialog which says that kded4 had a segmentation fault


Expected results: no crash


Additional info:
It seems after the first crash kded4 is restarted with the --nocrashhandler option and that seems to prevent most of the crashes. But I had at least once the case that after a resume kded4 was dead (and I didn't notice at first) leading to all kinds of strange behaviour in the KDE session.
Comment 1 Rex Dieter 2012-03-20 16:38:58 EDT
--nocrashhandler doesn't avoid crashes, it simply auto-restarts itself without notifying you.

In any case, we'd need a backtrace to investigate further.
Comment 2 Stefan Becker 2012-03-20 17:04:14 EDT
Created attachment 571526 [details]
information saved from kcrash dialog

I did the following

  - killed kded4
  - gdb /usr/bin/kded4
  - suspend
  - resume
  - switched to developer info in KCrash dialog

I installed the following -debuginfo packages:

qt-debuginfo-4.8.0-8.fc17.x86_64
glib2-debuginfo-2.31.20-1.fc17.x86_64
kdelibs-debuginfo-4.8.1-2.fc17.x86_64
Comment 3 Rex Dieter 2012-03-20 17:11:22 EDT
Here's the interesting thread:

Thread 1 (Thread 0x7ffff7893880 (LWP 4708)):
[KCrash Handler]
#6  0x0000003cdf986cc0 in QObject::property (this=0x8e0d00, name=0x3ce02613d0 "_qdbus_slotCache") at kernel/qobject.cpp:3741
#7  0x0000003ce0223c8c in QDBusConnectionPrivate::activateCall (this=this@entry=0x7c44e0, object=0x8e0d00, flags=flags@entry=273, msg=...) at qdbusintegrator.cpp:807
#8  0x0000003ce0224966 in QDBusConnectionPrivate::activateObject (this=0x7c44e0, node=..., msg=..., pathStartPos=<optimized out>) at qdbusintegrator.cpp:1423
#9  0x0000003ce0224a5b in QDBusActivateObjectEvent::placeMetaCall (this=0x80bea0) at qdbusintegrator.cpp:1537
#10 0x0000003cdf9890ee in QObject::event (this=0x8e0950, e=<optimized out>) at kernel/qobject.cpp:1195
#11 0x0000003ce21ca2dc in QApplicationPrivate::notify_helper (this=this@entry=0x6418a0, receiver=receiver@entry=0x8e0950, e=e@entry=0x80bea0) at kernel/qapplication.cpp:4550
#12 0x0000003ce21ce85a in QApplication::notify (this=0x7fffffffdc50, receiver=0x8e0950, e=0x80bea0) at kernel/qapplication.cpp:4411
#13 0x0000003ce3045806 in KApplication::notify (this=0x7fffffffdc50, receiver=0x8e0950, event=0x80bea0) at /usr/src/debug/kdelibs-4.8.1/kdeui/kernel/kapplication.cpp:311
#14 0x0000003cdf97482e in QCoreApplication::notifyInternal (this=0x7fffffffdc50, receiver=receiver@entry=0x8e0950, event=event@entry=0x80bea0) at kernel/qcoreapplication.cpp:876
#15 0x0000003cdf977fb1 in sendEvent (event=0x80bea0, receiver=0x8e0950) at kernel/qcoreapplication.h:231
#16 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60f4d0) at kernel/qcoreapplication.cpp:1500
#17 0x0000003cdf9a27c3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#18 postEventSourceDispatch (s=s@entry=0x642ec0) at kernel/qeventdispatcher_glib.cpp:279
#19 0x0000003cd3c4773c in g_main_dispatch (context=0x642e00) at gmain.c:2510
#20 g_main_context_dispatch (context=context@entry=0x642e00) at gmain.c:3047
#21 0x0000003cd3c47b58 in g_main_context_iterate (context=context@entry=0x642e00, block=block@entry=1, dispatch=dispatch@entry=1, self=<error reading variable: Unhandled dwarf expression opcode 0xfa>) at gmain.c:3118
#22 0x0000003cd3c47c14 in g_main_context_iteration (context=0x642e00, may_block=1) at gmain.c:3179
#23 0x0000003cdf9a2956 in QEventDispatcherGlib::processEvents (this=0x610990, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#24 0x0000003ce2269c0e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#25 0x0000003cdf97382f in QEventLoop::processEvents (this=this@entry=0x7fffffffd9d0, flags=...) at kernel/qeventloop.cpp:149
#26 0x0000003cdf973ab8 in QEventLoop::exec (this=0x7fffffffd9d0, flags=...) at kernel/qeventloop.cpp:204
#27 0x0000003cdf9782fc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#28 0x0000003cdec084e0 in kdemain (argc=1, argv=0x7fffffffdd98) at /usr/src/debug/kdelibs-4.8.1/kded/kded.cpp:924
#29 0x0000003cd4021735 in __libc_start_main () from /lib64/libc.so.6
#30 0x00000000004007a1 in _start ()
Comment 4 Rex Dieter 2012-05-14 14:01:34 EDT
It was a bluedevil bug, fixed in 
https://admin.fedoraproject.org/updates/FEDORA-2012-6665/bluedevil-1.3-0.3.rc1.fc17
Comment 5 Rex Dieter 2012-05-14 14:01:47 EDT
*** Bug 806075 has been marked as a duplicate of this bug. ***
Comment 6 Rex Dieter 2012-05-14 14:02:35 EDT
*** Bug 794955 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.