Bug 805312 - fedora-readonly.service and StandardInput=tty resets console during boot
fedora-readonly.service and StandardInput=tty resets console during boot
Status: CLOSED DUPLICATE of bug 785662
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-20 16:39 EDT by Daniel Drake
Modified: 2014-03-16 23:30 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-20 17:19:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Drake 2012-03-20 16:39:51 EDT
In new versions of systemd, setting StandardInput=tty causes the tty to be reset during boot, including a switch to text mode.

If plymouth is booting drawing on the framebuffer (no KMS) then this causes the splash graphics to be wiped from the screen while the system is booting and loading the unit file.

I can't see any good reason why fedora-readonly.service has StandardInput=tty. Can this be removed?
Other service files installed by initscripts should be reviewed at the same time.
Comment 1 Bill Nottingham 2012-03-20 17:19:52 EDT

*** This bug has been marked as a duplicate of bug 785662 ***

Note You need to log in before you can comment on or make changes to this bug.