Bug 805536 - Notification conditions removed if alert conditions are edited.
Notification conditions removed if alert conditions are edited.
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Monitoring - Alerts (Show other bugs)
JON 3.0.0
Unspecified Unspecified
medium Severity medium
: ER03
: JON 3.2.0
Assigned To: Jirka Kremser
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-21 10:30 EDT by Naveen Malik
Modified: 2014-01-02 15:37 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Naveen Malik 2012-03-21 10:30:45 EDT
Description of problem:
When you remove conditions from an alert that has notifications fired, the conditions for the previously fired notifications are cleared showing "No Conditions" in history and "No items to show." under the notification detail's Conditions tab.

Version-Release number of selected component (if applicable):
3.0

How reproducible:
Always.

Steps to Reproduce:
1. Create an alert.
2. Wait for alert to fire notification.
3. Verify notification has condition text set in history tab.
4. Edit alert, removing conditions.
5. Check condition text is empty in history tab.
  
Actual results:
Conditions are cleared.

Expected results:
Conditions remain the values of the condition when the notification fired.
Comment 1 Mike Foley 2012-03-26 11:57:36 EDT
medium, no target release 

per bz triage (crouch, mfoley, asantos, loleary)
Comment 2 Larry O'Leary 2013-10-08 09:17:29 EDT
I believe this was fixed as part of the work done for bug 914631. Jirka, can you confirm and if so, move this to ON_QA with an ER03 target milestone?
Comment 3 Jirka Kremser 2013-10-08 10:43:34 EDT
Confirming. I tried the repro steps and it's working. Setting the target release to ER4, because ER3 is already out.
Comment 6 Sunil Kondkar 2013-11-15 07:16:54 EST
Verified on version : 3.2.0.ER5 Build Number : 2cb2bc9:225c796

Note You need to log in before you can comment on or make changes to this bug.