Bug 805588 - minor init script formatting and consistency issues
minor init script formatting and consistency issues
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sblim-sfcb (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Vitezslav Crhonek
qe-baseos-daemons
:
: 1016574 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-21 12:14 EDT by Kwan Lowe
Modified: 2017-03-21 06:05 EDT (History)
2 users (show)

See Also:
Fixed In Version: sblim-sfcb-1.3.11-5.el6
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-21 06:05:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kwan Lowe 2012-03-21 12:14:09 EDT
Description of problem:
This is a *VERY MINOR* output formatting issue. When running "service sblim-sfcb status|start|stop" the newlines are suppressed in the output. This causes the output to display incorrectly.

Version-Release number of selected component (if applicable):

sblim-sfcb-1.3.11-2.el6.i686

How reproducible:
Run:  service sblim status

Steps to Reproduce:
1.
2.
3.
  
Actual results:

[root@rhlinbox ~]# service sblim-sfcb status
sfcb (11636 11629) is running[root@rhlinbox ~]#

[root@rhlinbox ~]# service sblim-sfcb start
[root@rhlinbox ~]# _                                       [  OK  ]



Expected results:
[root@rhlinbox ~]# service sblim-sfcb status
sfcb (11636 11629) is running
[root@rhlinbox ~]#

[root@rhlinbox ~]# service sblim-sfcb start
Starting sblim-sfcb:                                     [  OK  ]
[root@rhlinbox ~]# _                           



Additional info:
Comment 2 RHEL Product and Program Management 2012-09-07 01:07:31 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 Vitezslav Crhonek 2013-10-08 07:28:40 EDT
*** Bug 1016574 has been marked as a duplicate of this bug. ***
Comment 4 RHEL Product and Program Management 2013-10-13 20:45:25 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 6 Vitezslav Crhonek 2016-10-03 08:26:35 EDT
I've also noticed that there is faulty check for "/var/run/tog-pegasus.pid" in "service sblim-sfcb status". If tog-pegasus is running and sblim-sfcb is stopped, then partially incorrect information is returned:

# service sblim-sfcb status
sfcb is not running, but pid file exists
Comment 8 Alois Mahdal 2017-01-12 19:59:52 EST
Verified with sblim-sfcb-1.3.11-5.el6:

 *  all `service` messages are formatted properly,

 *  the status described in comment 6 does not mention PID file
    anymore.
Comment 10 errata-xmlrpc 2017-03-21 06:05:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0648.html

Note You need to log in before you can comment on or make changes to this bug.