Bug 805748 - The statistic of system on "Dashboard" is inconsistent with "Systems".
The statistic of system on "Dashboard" is inconsistent with "Systems".
Status: CLOSED CURRENTRELEASE
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.0.0
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Bryan Kearney
Entitlement Bugs
: Triaged
Depends On:
Blocks: sam11-tracker
  Show dependency treegraph
 
Reported: 2012-03-21 22:17 EDT by Hui Wang
Modified: 2012-08-22 10:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When using virt-who or the ueber certificate, the system count will be incremented. This will be fixed in a future release.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-22 10:54:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Total system in Dashboard (117.88 KB, image/png)
2012-03-21 22:19 EDT, Hui Wang
no flags Details
Total system in Systems (158.81 KB, image/png)
2012-03-21 22:20 EDT, Hui Wang
no flags Details
total system in System before i delete the ESX (159.11 KB, image/png)
2012-05-22 03:48 EDT, yqiao
no flags Details
total system in DAshboard before i delete the ESX (113.91 KB, image/png)
2012-05-22 03:49 EDT, yqiao
no flags Details
total system in Dashboard after i delete the ESX (109.11 KB, image/png)
2012-05-22 03:51 EDT, yqiao
no flags Details
total system in System after i delete the ESX (118.26 KB, image/png)
2012-05-22 03:51 EDT, yqiao
no flags Details

  None (edit)
Description Hui Wang 2012-03-21 22:17:54 EDT
Description of problem:

The total systems statistic on Dashboard is 6, but on Systems tab page is 7.
The total systems on Dashboard may be not contains ESX system.
See the attachments.

Version-Release number of selected component (if applicable):
katello-cli-headpin-0.1.16-1.el6.noarch
katello-headpin-0.1.143-1.el6.noarch
katello-common-0.1.304-1.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.0.4-1.el6.noarch
katello-headpin-all-0.1.143-1.el6.noarch
katello-configure-0.1.106-1.el6.noarch
katello-glue-candlepin-0.1.304-1.el6.noarch
katello-cli-common-0.1.105-1.el6.noarch
katello-selinux-0.1.9-1.el6.noarch
candlepin-0.5.26-1.el6.noarch
candlepin-tomcat6-0.5.26-1.el6.noarch
thumbslug-0.0.21-1.el6.noarch


How reproducible:


Steps to Reproduce:
1.Install some hosts (include kvm, xen, rhev-h, ESX) and guests.
2.Register all the hosts to SAM and subscribe some system to SAM.
3.Check the total systems on "Dashboard" and "System" tab page
  
Actual results:
The statistic of system in "Dashboard" is inconsistent with "Systems".

Expected results:
The statistic of system in "Dashboard" is consistent with "Systems".

Additional info:
Comment 1 Hui Wang 2012-03-21 22:19:03 EDT
Created attachment 571899 [details]
Total system in Dashboard
Comment 2 Hui Wang 2012-03-21 22:20:27 EDT
Created attachment 571901 [details]
Total system in Systems
Comment 5 Hui Wang 2012-03-21 22:47:20 EDT
(In reply to comment #0)
> Description of problem:
> 
> The total systems statistic on Dashboard is 6, but on Systems tab page is 7.
> The total systems on Dashboard may be not contains ESX system.

The number of systems on Dashboard does not change when I remove the ESX system from Systems. But if I remove other systems, the number of systems on Dashboard will change.
Comment 6 Jordan OMara 2012-03-27 15:39:13 EDT
I was able to reproduce this bug using an esx client and virt-who on another machine. From the database, here's whats happening:

 8a8b67c73654462c0136555deee80339 | 2012-03-27 14:14:41.128 | 2012-03-27 14:14:41.769 | t        | valid             |                         | ueber_cert_consumer   |            |              | admin    | 7a968642-61af-4d2
7-a799-23f3002abd75 |                |                                  | 8a8b67c73654462c0136555df164033c | 8a8b67c73654462c0136544709fd0001 | 8a8b67c7365445f60136544607760001
 8a8b67c73654462c0136555718fb0332 | 2012-03-27 14:07:13.147 | 2012-03-27 14:17:45.539 | t        | invalid           | 2012-03-27 14:17:45.539 | maccy                 |            |              | admin    | 0c83885e-eb31-4b5
a-9533-5bb3337800c2 | 2              | 8a8b67c73654462c013655571c9d0335 | 8a8b67c73654462c013655571c7d0334 | 8a8b67c73654462c0136544709fd0001 | 8a8b67c7365445f60136544607760001
 8a8b67c73654462c0136558a3e67038d | 2012-03-27 15:03:05.063 | 2012-03-27 15:03:06.062 | t        | invalid           |                         | localhost.localdomain |            |              | admin    | 90aa32f6-3296-404
9-9eca-1ff7ded39937 | 2              | 8a8b67c73654462c0136558a42320390 | 8a8b67c73654462c0136558a420c038f | 8a8b67c73654462c0136544709fd0001 | 8a8b67c7365445f60136544607760001

Maccy is the third party running virt-who and localhost.localdomain is the esx client. The problem is that it creates an extra consumer called ueber_cert_consumer. The front page, dashboard, calls "owner info" to get the list of consumers, which returns this. The systems page just looks to elasticsearch, which has not registered an ueber_cert_consumer and thus shows one less than the front page.

This is not exactly a duplicate, but is a similar problem, of bz 805027
Comment 8 Bryan Kearney 2012-04-10 13:06:58 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
When using virt-who or the ueber certificate, the system count will be incremented. This will be fixed in a future release.
Comment 10 yqiao 2012-05-22 03:44:22 EDT
The bug has been fixed and passed.

my Version-Release number of selected components:
katello-configure-0.3.3-2.el6_2.noarch
katello-headpin-all-0.2.6-4.el6_2.noarch
katello-common-0.3.1-1.el6_2.noarch
katello-cli-common-0.3.2-3.el6_2.noarch
katello-headpin-0.2.6-4.el6_2.noarch
katello-glue-candlepin-0.3.1-1.el6_2.noarch
katello-cli-headpin-0.2.0-1.el6_2.noarch
katello-selinux-0.2.4-1.el6_2.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.1.5-1.el6_2.noarch
candlepin-0.6.2-1.el6_2.noarch
katello-glue-candlepin-0.3.1-1.el6_2.noarch
candlepin-tomcat6-0.6.2-1.el6_2.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
thumbslug-0.0.24-1.el6_2.noarch
Comment 11 yqiao 2012-05-22 03:48:08 EDT
Created attachment 585951 [details]
total system in System before i delete the ESX
Comment 12 yqiao 2012-05-22 03:49:46 EDT
Created attachment 585952 [details]
total system in DAshboard before i delete the ESX
Comment 13 yqiao 2012-05-22 03:51:02 EDT
Created attachment 585953 [details]
total system in Dashboard after i delete the ESX
Comment 14 yqiao 2012-05-22 03:51:48 EDT
Created attachment 585954 [details]
total system in System after i delete the ESX

Note You need to log in before you can comment on or make changes to this bug.