Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
I'm not 100% sure of the validity of this, but it resulted from one of our own tools. After creating a few vm hosts (using a python script in katello git) and subsequently deleting said hosts, candlepin errors are thrown.
Setting priority to low, it can be elevated if deemed to be a real world scenario
Version-Release number of selected component (if applicable):
How reproducible:
Steps to Reproduce:
1. View bug #784009 repeat steps 1-3 therein, assuring hosts are created.
2. In webui, navigate to Systems > All
3. Noting the two newly created vm hosts in the ui, remove them.
4. rerun the script
Actual results:
* Error about candlepin not being able to find hosts:
Candlepin::CandlepinResource: 410 Gone {"displayMessage":"Consumer host1 has been deleted","deletedId":"host1"} (GET /candlepin/consumers/host1/compliance)
* No systems ever appear in view
Expected results:
If vm hosts are deleted (and perhaps subsequently recreated), everything should be handled cleanly.
Additional info:
Seems fix to bug #802263 solved the problem with 410 when viewing the system list after deleting the hypervisors, the one thing that left is enable the hypervisor after deleting it to be able to register it again (when trying to register it again, candlepin says it has been deleted previously, which is correct in case you really don't wont to register the hypervisor).
However I'm not sure if there should be a command in CLI for that (system enable_hypervisor --uuid {{UUID}}) or if it could be an option for virt-who script, to indicate that some hypervisor should be enabled by force.