Bug 805752 - Systems: Deleting hypervisors (?) possibly causes errors to show up in system view
Systems: Deleting hypervisors (?) possibly causes errors to show up in system...
Status: CLOSED DUPLICATE of bug 812891
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
low Severity low (vote)
: Unspecified
: --
Assigned To: Eric Helms
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-21 22:25 EDT by Corey Welton
Modified: 2013-08-16 14:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-10 15:13:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2012-03-21 22:25:51 EDT
Description of problem:

I'm not 100% sure of the validity of this, but it resulted from one of our own tools. After creating a few vm hosts (using a python script in katello git) and subsequently deleting said hosts, candlepin errors are thrown.  

Setting priority to low, it can be elevated if deemed to be a real world scenario

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  View bug #784009 repeat steps 1-3 therein, assuring hosts are created.
2.  In webui, navigate to Systems > All
3.  Noting the two newly created vm hosts in the ui, remove them.
4.  rerun the script
  
Actual results:

* Error about candlepin not being able to find hosts:

Candlepin::CandlepinResource: 410 Gone {"displayMessage":"Consumer host1 has been deleted","deletedId":"host1"} (GET /candlepin/consumers/host1/compliance)

* No systems ever appear in view

Expected results:
If vm hosts are deleted (and perhaps subsequently recreated), everything should be handled cleanly.

Additional info:
Comment 1 Corey Welton 2012-03-21 22:32:50 EDT
test notes: running the script referenced in bug #784009 requires python-rhsm 0.99.2 or higher.
Comment 2 Mike McCune 2012-03-21 23:11:18 EDT
looks like a dupe of:

https://bugzilla.redhat.com/show_bug.cgi?id=802263
Comment 3 Mike McCune 2012-03-22 19:24:09 EDT
Will leave this bug open thou
Comment 5 Ivan Necas 2012-05-07 05:50:02 EDT
Seems fix to bug #802263 solved the problem with 410 when viewing the system list after deleting the hypervisors, the one thing that left is enable the hypervisor after deleting it to be able to register it again (when trying to register it again, candlepin says it has been deleted previously, which is correct in case you really don't wont to register the hypervisor).

However I'm not sure if there should be a command in CLI for that (system enable_hypervisor --uuid {{UUID}}) or if it could be an option for virt-who script, to indicate that some hypervisor should be enabled by force.
Comment 7 Jordan OMara 2012-05-10 15:13:57 EDT
This didn't actually get set as a dupe, but it is. Closing

*** This bug has been marked as a duplicate of bug 812891 ***
Comment 9 Mike McCune 2013-08-16 14:05:43 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.