This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 812891 - RFE: headpin cli method for removing a deletion record on a hypervisor
RFE: headpin cli method for removing a deletion record on a hypervisor
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.0.0
Unspecified Unspecified
high Severity high
: rc
: 1.X
Assigned To: Jordan OMara
SAM QE List
: FutureFeature, TestBlocker, Triaged
: 805752 (view as bug list)
Depends On: 802263
Blocks: sam11-tracker 820742
  Show dependency treegraph
 
Reported: 2012-04-16 09:44 EDT by Chris Duryee
Modified: 2014-11-09 17:55 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Removal of hypervisors created a deletion record. This record stopped hypervisors from re-registering with the same UUID. This update provides deletion record removal: # headpin system remove_deletion --uuid=<uuid>
Story Points: ---
Clone Of: 802263
: 820742 (view as bug list)
Environment:
Last Closed: 2012-06-20 11:20:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Jordan OMara 2012-05-10 15:13:57 EDT
*** Bug 805752 has been marked as a duplicate of this bug. ***
Comment 4 Jordan OMara 2012-05-10 15:18:37 EDT
Feature added in pull request https://github.com/Katello/katello/pull/96
263e6f48986f372f0ce674f9327d4e6c2acefcea

Usage:
[root~]# headpin -u admin -p admin system remove_deletion --uuid=500
Comment 6 Hui Wang 2012-06-04 01:52:21 EDT
Verified the bug. The result is PASS.
Build:
SAM-2012-05-31.1

step:
1. Restart virt-who service
[root@7234 ~]# service virt-who restart
Stopping virt-who:                                         [  OK  ]
Starting virt-who:                                         [  OK  ]
Listening for events is not available in VDSM or ESX mode
[root@7234 ~]# Virt-who is running in esx mode
Starting infinite loop with 3600 seconds interval and event handling
Sending update in hosts-to-guests mapping: {44454c4c-4c00-1031-8053-b8c04f4e3258: [421f875f-f7f1-4743-ad34-cffda0abc4a2, 421febe8-208a-3072-0a0d-c4d641f0dd01, 420a6910-75c5-ec7d-8890-186bed705daa], 44454c4c-4200-1034-8039-b8c04f503258: [421f1822-367a-dff2-837a-d0b63712ae27, 42372e7b-20e5-03fb-9435-e45f2fe5fb43, 421f931a-9067-d179-8a19-6f7a7c9993ef]}
Updated host: 44454c4c-4c00-1031-8053-b8c04f4e3258 with guests: [421f875f-f7f1-4743-ad34-cffda0abc4a2, 421febe8-208a-3072-0a0d-c4d641f0dd01, 420a6910-75c5-ec7d-8890-186bed705daa]
Updated host: 44454c4c-4200-1034-8039-b8c04f503258 with guests: [421f1822-367a-dff2-837a-d0b63712ae27, 42372e7b-20e5-03fb-9435-e45f2fe5fb43, 421f931a-9067-d179-8a19-6f7a7c9993ef]
2. Remove the ESX registered host to unregister the machine from SAM.
3. Remove the the deletion record of the ESX machine
# headpin -u admin -p admin system remove_deletion --uuid=44454c4c-4200-1034-8039-b8c04f503258
Successfully removed deletion record for hypervisor with uuid [ 44454c4c-4200-1034-8039-b8c04f503258 ]
4. Checking the systems that registered on SAM, the unregistered ESX machine re-registered to SAM.
Comment 7 sachua 2012-06-13 23:59:49 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
When a hypervisor is removed from SAM, a deletion record is created so that the hypervisor cannot re-register with the same UUID. This updates allows users to re-register a hypervisor after an accidental deletion by removing the deletion record using this command:
# headpin -u admin -p admin system remove_deletion --uuid=<system uuid>
Comment 8 sachua 2012-06-14 00:00:14 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,2 +1,2 @@
-When a hypervisor is removed from SAM, a deletion record is created so that the hypervisor cannot re-register with the same UUID. This updates allows users to re-register a hypervisor after an accidental deletion by removing the deletion record using this command:
+When a hypervisor is removed from SAM, a deletion record is created so that the hypervisor cannot re-register with the same UUID. This update allows users to re-register a hypervisor after an accidental deletion by removing the deletion record using this command:
 # headpin -u admin -p admin system remove_deletion --uuid=<system uuid>
Comment 9 Dan Macpherson 2012-06-15 01:20:09 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,2 +1,3 @@
-When a hypervisor is removed from SAM, a deletion record is created so that the hypervisor cannot re-register with the same UUID. This update allows users to re-register a hypervisor after an accidental deletion by removing the deletion record using this command:
+Removal of hypervisors created a deletion record. This record stopped hypervisors from re-registering with the same UUID. This update provides deletion record removal:
-# headpin -u admin -p admin system remove_deletion --uuid=<system uuid>+
+# headpin system remove_deletion --uuid=<uuid>
Comment 11 errata-xmlrpc 2012-06-20 11:20:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1021.html

Note You need to log in before you can comment on or make changes to this bug.