Bug 805784 - take rhel6 kexec patches which are not merged in upstream
take rhel6 kexec patches which are not merged in upstream
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dave Young
Fedora Extras Quality Assurance
:
: 604055 (view as bug list)
Depends On:
Blocks: RHEL7KdumpTracker
  Show dependency treegraph
 
Reported: 2012-03-22 02:09 EDT by Dave Young
Modified: 2013-01-10 03:28 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-30 23:31:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Young 2012-03-22 02:09:14 EDT
Description of problem:

Need verify, if there's patches which are not in upstream we should try make them upstream. If we can't we should take them in fedora kexec-tools rpm

Related rhel6 bzs:
-kexec [not upstream stuff]
O [kexec not upstream merged?] 567871,"Execshield stack protection is
disabled for sbin/kexec on ppc"
O bz593109[kexec bug this bz & kernel bug 593111, not upstream?],"[6.0]
kdump(2nd kernel) does not start."


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Fedora Admin XMLRPC Client 2012-04-16 02:12:04 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 CAI Qian 2012-05-21 09:59:03 EDT
*** Bug 604055 has been marked as a duplicate of this bug. ***
Comment 3 Dave Young 2012-06-18 23:23:44 EDT
status update:

567871,"Execshield stack protection is disabled for sbin/kexec on ppc"

Verified, there's no such issue with ppc64, this should only limited to ppc32, so it does not matter for us, anyway I will verify on my mac mini if I have time.

bz593109 kdump(2nd kernel) does not start.

This one is a UEFI problem, looks a little complex. Will test it on an uefi booting machine to see if this is still a issue with rhel7.
Comment 4 Dave Young 2012-06-20 05:12:16 EDT
Add mjg into cc list.

Matthew, could you help to verify the bz593109? It related to some uefi patches for rhel6, I'm not sure it they are valid for rhel7. I tested F17 efi without any other modification except of the rsdp passing, test results looks good.

If the patches mentioned in bz593109 is not valid for rhel7, I will just close this bug.

Thanks a lot in advance.
Comment 5 Dave Young 2012-08-30 23:31:22 EDT
create bug 849650 for efi cmdline param issue. Closing this bug.

Note You need to log in before you can comment on or make changes to this bug.