This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 805813 - the seventh test (random number sequence) fails at about 129 MiB
the seventh test (random number sequence) fails at about 129 MiB
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: memtest86+ (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
AcceptedNTH
:
: 807844 (view as bug list)
Depends On:
Blocks: F17Blocker/F17FinalBlocker F17Beta-accepted/F17BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-03-22 05:08 EDT by Karel Volný
Modified: 2012-03-29 00:12 EDT (History)
3 users (show)

See Also:
Fixed In Version: memtest86+-4.20-6.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-29 00:12:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot of the problem (25.50 KB, image/png)
2012-03-22 05:09 EDT, Karel Volný
no flags Details
Temporal workaround (1.34 KB, patch)
2012-03-22 10:06 EDT, Jaroslav Škarvada
no flags Details | Diff

  None (edit)
Description Karel Volný 2012-03-22 05:08:21 EDT
Description of problem:
Trying to run the latest memtest86+ on various hardware, even in qemu, the seventh test (Random number sequence) fails and reports errors for each address from 129 MiB on.

Version-Release number of selected component (if applicable):
memtest86+ 4.20 from Fedora 17 Alpha DVD

How reproducible:
always

Steps to Reproduce:
1. qemu-kvm -m 1024 -cdrom Fedora-17-Alpha-x86_64.DVD.iso
2. choose Troubleshooting => Run memory test
  
Actual results:
see the attached screenshot

Expected results:
no errors

Additional info:
Initially, I've run this on Intel SandyBridge hardware - Pentium B950 with some Samsung memories, and it failed this way, leading me to unjustified warranty claim ...
After that, I've verified the same memtest behaviour on T510 with Core i7 M620, and on some older desktop with Core i5 - real hardware, proven by months of service => seeing the same all the time I've tried in qemu and it fails too.
Comment 1 Karel Volný 2012-03-22 05:09:08 EDT
Created attachment 571941 [details]
screenshot of the problem
Comment 2 Jaroslav Škarvada 2012-03-22 10:06:12 EDT
Created attachment 572002 [details]
Temporal workaround

Thanks for reporting. It seems to be related to gcc-4.7 update. Temporal workaround patch is attached (it could negatively affect performance).
Scratch build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=3922148
I am working on better patch.
Comment 3 Fedora Update System 2012-03-27 05:13:39 EDT
memtest86+-4.20-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/memtest86+-4.20-6.fc17
Comment 4 Adam Williamson 2012-03-27 14:08:06 EDT
Proposing as Final blocker, though it's somewhat arguable. Criterion: "All release media must include a standalone memory test utility. A boot menu option to launch this utility must be present and must work correctly. "

Also proposing as Beta NTH, it would be good to ensure the memtest in Beta works.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Fedora Update System 2012-03-28 01:59:57 EDT
Package memtest86+-4.20-6.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing memtest86+-4.20-6.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4808/memtest86+-4.20-6.fc17
then log in and leave karma (feedback).
Comment 6 Przemek Klosowski 2012-03-28 17:35:11 EDT
*** Bug 807844 has been marked as a duplicate of this bug. ***
Comment 7 Adam Williamson 2012-03-28 20:11:05 EDT
Discussed at 2012-03-28 go/no-go meeting, acting as an NTH review meeting. Accepted as NTH: this can't be fixed with an update, and it's obviously visibly bad to have broken memtest on our beta images.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Fedora Update System 2012-03-29 00:12:23 EDT
memtest86+-4.20-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.