Bug 805986 - [REST API] Provide an URL to check the availability of an application
[REST API] Provide an URL to check the availability of an application
Status: CLOSED DUPLICATE of bug 805989
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Krishna Raman
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-22 11:55 EDT by Xavier Coulon
Modified: 2015-05-14 21:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-23 06:53:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xavier Coulon 2012-03-22 11:55:52 EDT
Have a mean to get the availability of a given application (CREATED vs CREATED) to know if the client can clone/import it locally, either by providing an URL or by returning its state when querying the application (GET ..)
Comment 1 Rob Millner 2012-03-22 22:12:55 EDT
Is this a duplicate of 805989?
Comment 2 Andre Dietisheim 2012-03-23 06:47:59 EDT
Yes, we decided to suggest a single solution to the following 3 issues: 

* https://bugzilla.redhat.com/show_bug.cgi?id=805986 (application availability after creation)
* https://bugzilla.redhat.com/show_bug.cgi?id=806008 (application availability after creation)
* https://bugzilla.redhat.com/show_bug.cgi?id=805989 (application started/stopped state)

We suggest that a single state property would inform about the state an application is in. States contains information about creation and running.
Comment 3 Xavier Coulon 2012-03-23 06:53:53 EDT

*** This bug has been marked as a duplicate of bug 805989 ***

Note You need to log in before you can comment on or make changes to this bug.