Bug 80600 - starts with wrong default serial DEVICE and kills my mouse
starts with wrong default serial DEVICE and kills my mouse
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-mouse (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks: 79579 CambridgeTarget
  Show dependency treegraph
 
Reported: 2002-12-28 11:51 EST by Michael Schwendt
Modified: 2007-04-18 12:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-10 14:22:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2002-12-28 11:51:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
The working configuration for my mouse is this:

$ cat /etc/sysconfig/mouse
FULLNAME="Generic - 3 Button Mouse (serial)"
MOUSETYPE="Microsoft"
XEMU3="no"
XMOUSETYPE="generic3"
DEVICE=/dev/ttyS1
OPTIONS="-t imps2 -m /dev/input/mice -M"

When I run redhat-config-mouse within the X Window System, it preselects
"Generic > 3 Button Mouse (serial)". So far so good. When I click "OK" without
clicking the "Serial devices" button and without choosing the correct serial
device there, it always activates /dev/ttyS0 instead of /dev/ttyS1.  That is a
trap. It should not alter my configuration unless I tell it to do so. Internally
it selects "/dev/ttyS0 (COM1 under DOS)" as a starting value in the "Serial
devices" sub-dialog. It should take the current DEVICE from /etc/sysconfig/mouse.

Worse, even if I choose /dev/ttyS1 in the "Serial devices" dialog and exit with
"OK", it kills my mouse  in X by restarting gpm:

$ redhat-config-mouse 
Shutting down console mouse services:                      [  OK  ]
Starting console mouse services:                           [  OK  ]

Effectively, within X, redhat-config-mouse always (!) kills my mouse and I need
to fix it from text mode. Running redhat-config-mouse (or redhat-config-mouse
--device /dev/ttyS1) in text mode also restarts gpm, but repairs the non-working
mouse in my current X session.


Version-Release number of selected component (if applicable):
1.0.2-10

How reproducible:
Always
Comment 1 Brent Fox 2003-01-14 09:11:22 EST
Right.  This happens in both GUI and TUI modes, but it should be fixed in
redhat-config-mouse-1.0.3-1, which should appear in Rawhide in the next day or
so.  QA, please verify.
Comment 2 Jay Turner 2003-01-15 10:14:26 EST
With redhat-config-mouse-1.0.3-1, if I click "OK" without going into the "Serial
Devices" selection, I get the following traceback:

Traceback (most recent call last):
  File "/usr/lib/python2.2/site-packages/rhpl/firstboot_gui_window.py", line 83,
in okClicked
    if self.apply():
  File "/usr/share/redhat-config-mouse/mouse_gui.py", line 338, in apply
    port = self.deviceStore.get_value(iter, 1)
TypeError: iter must be a GtkTreeIter
Comment 3 Brent Fox 2003-01-15 16:55:28 EST
Oops, I didn't test that case.  Try again with redhat-config-mouse-1.0.3-2.
Comment 4 Jay Turner 2003-02-03 12:35:14 EST
I'm still seeing the same traceback with 1.0.4-1 (latest in Beehive at the moment.)
Comment 5 Brent Fox 2003-02-03 14:09:54 EST
I must be losing my mind.  I think I've fixed it for real this time with
redhat-config-mouse-1.0.4-2.  Sorry for the problems.
Comment 6 Brent Fox 2003-05-25 10:30:24 EDT
There is a stack of 64 bugs that have been in Modified state for a long period
of time.  I am closing these as Rawhide now.  If you find that the issue is not
fixed, please reopen this report.
Comment 7 Michael Schwendt 2003-05-25 10:55:41 EDT
Let me add my bit of QA then. ;o)

It no longer kills the current mouse h/w configuration, *but* now it creates a
bad configuration file silently.

My working config:

$ cat /etc/sysconfig/mouse
FULLNAME="Generic - 3 Button Mouse (serial)"
MOUSETYPE="Microsoft"
XEMU3="no"
XMOUSETYPE="Microsoft"
DEVICE=/dev/ttyS1

Update the tool to most recent version from Raw Hide:

$ rpm -q redhat-config-mouse 
redhat-config-mouse-1.0.6-2

I start it, enter root password. It preselects "3 Button Mouse (serial)" which
looks fine. I click "OK" without touching anything else. As explained earlier,
it chooses the wrong serial device internally:

$ cat /etc/sysconfig/mouse
FULLNAME="Generic - 3 Button Mouse (serial)"
MOUSETYPE="Microsoft"
XEMU3="no"
XMOUSETYPE="Microsoft"
DEVICE=/dev/ttyS0

Therefore, next time I would reboot or restart X, my mouse wouldn't work any longer.

I run redhat-config-mouse again, open the "Serial devices" dialog, change from
ttyS0 to ttyS1 and leave with OK. That creates a good config file.

Conclusion: Upon starting the tool, it should preselect the DEVICE= found in
/etc/sysconfig/mouse and NOT change it unless it performs working h/w device
detection or if the users tells it to use a different device.
Comment 8 Brent Fox 2003-09-10 14:22:54 EDT
Ok, should be fixed in redhat-config-mouse-1.0.11.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.