Bug 80614 - Mouse pointer erratic
Mouse pointer erratic
Status: CLOSED DUPLICATE of bug 80309
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-12-28 14:31 EST by Ted Kaczmarek
Modified: 2008-01-17 12:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:50:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ted Kaczmarek 2002-12-28 14:31:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20021225

Description of problem:
I am using Logitech MouseManPlus/PS2, the pointer is erratic to the point where
it is not usable.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Install Phoebe
2.Setup X for MouseManPlus/PS2 protocol

Actual Results:  Mouse is uncontrollable, hops all over the desktop.

Expected Results:  Mouse behaves properly.

Additional info:

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "MouseManPlusPS/2"
        Option      "Device" "/dev/psaux"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "no"

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
        Identifier  "DevInputMice"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "no"

Snippet from config, why are their two Section "InputDevice" ?
Comment 1 Warren Togami 2002-12-28 16:31:27 EST
Two mice are configured automatically when you set "PS/2" in redhat-config-mouse
or anaconda in order to accomodate hotplug USB mice.  This is very handy for
laptops but unfortunately something in the kernel is broken that is preventing
it from working at the moment (Bug 80359).

I suspect that your erratic pointer behavior is due to the gpm bug (Bug 80309).
 Please try disabling gpm with "service gpm stop; chkconfig gpm off".  If this
fixes the pointer behavior in X, please close this as a duplicate to Bug 80309.
Comment 2 Ted Kaczmarek 2002-12-28 16:44:18 EST

*** This bug has been marked as a duplicate of 80309 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:50:44 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.