Bug 806181 - RFE: Inject metadata for discoverability
RFE: Inject metadata for discoverability
Status: CLOSED DUPLICATE of bug 836838
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lee Newson
: Reopened
Depends On:
Blocks: 839461
  Show dependency treegraph
 
Reported: 2012-03-23 02:13 EDT by Joshua Wulf
Modified: 2014-10-19 19:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-20 05:38:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-03-23 02:13:32 EDT
I'd like the tags that my topic is tagged with to be written into the <sectioninfo> element when it is built by Skynet/CSP.

Some categories' tags probably shouldn't be injected, like internal workflow stuff, so maybe we could have a flag on each category to say whether it should be exposed in HTML.
Comment 1 Joshua Wulf 2012-03-23 03:25:28 EDT
I have an "SEO Metadata" category in the metadata schema.

What would be really good is an seo:enhances relationship between tags, which gives us the ability to do this:

TagX.seo:enhances.TagY

so that I could do:

SEOMetadata:"translation manager".seo:enhances.Technology:Zanata
SEOMetadata:"translation memory".seo:enhances.Technology:Zanata

Then, when Skynet's semantic processor is building the output, it will take a topic that has been tagged with "Zanata" and inject "Zanata" into the <sectioninfo> element of the topic, and it will additionally inject all tags that "seo:enhance" the Zanata tag, so it will also automatically inject "translation manager" and "translation memory" into the <sectioninfo>.

This means that metadata can be optimized for SEO at the level of the metadata schema, and authors just tag their topics like normal, and inherit all the Google Juice.
Comment 2 Joshua Wulf 2012-03-23 03:29:25 EDT
So you could do things like put "eap6" and "eap 6" into the SEO Metadata category and have them seo:enhance the EAP 6 release tags.
Comment 3 Joshua Wulf 2012-05-16 06:42:35 EDT
http://www.docbook.org/tdg/en/html/keywordset.html
http://www.docbook.org/tdg/en/html/sectioninfo.html

Currently looks like these are not injected into the meta section of the html output. 

Might need an xsl adjustment in addition to creating the <sectioninfo> element.
Comment 4 Matthew Casperson 2012-07-09 23:30:12 EDT

*** This bug has been marked as a duplicate of bug 836838 ***
Comment 5 Lee Newson 2012-09-20 05:38:28 EDT

*** This bug has been marked as a duplicate of bug 836838 ***

Note You need to log in before you can comment on or make changes to this bug.