Bug 836838 - Generate <keyset> from tags
Generate <keyset> from tags
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Matthew Casperson
:
: 806181 (view as bug list)
Depends On:
Blocks: 861203
  Show dependency treegraph
 
Reported: 2012-07-01 17:51 EDT by Matthew Casperson
Modified: 2014-08-04 18:27 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.27.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-06 21:31:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthew Casperson 2012-07-01 17:51:27 EDT
Email copied below
-----------------------

On 06/21/2012 04:33 PM, Cheryn Tan wrote:
> IIUC you've already been tagging the topics with keywords to 
> facilitate your navigation through the topics, and building of books. 
> They might not be an exact match for Google-friendly keywords, but I 
> imagine it's a good starting point. Pardon my vague terms, but is 
> there a way to convert these currently existing tags on the topics 
> into keywords visible to search engines? 

When the DocBook is transformed into HTML, the DocBook <keyword>s are 
processed into HTML <meta> tags. If the CCMS is already tracking this 
information, it could build it into <keywordset>s automatically.

Cheers
Rudi
Comment 1 Matthew Casperson 2012-07-09 23:30:12 EDT
*** Bug 806181 has been marked as a duplicate of this bug. ***
Comment 2 Lee Newson 2012-09-20 05:38:28 EDT
*** Bug 806181 has been marked as a duplicate of this bug. ***
Comment 3 Lee Newson 2012-09-20 05:43:41 EDT
Added in 0.27.0.

All topics now have tags that are in the following categories added as <keyword>s:

- Technology
- Release
- SEO Metadata
- Common Name
- Concern
- Content Type
- Programming Language

These are currently hardcoded but will be moved to some sort of changeable value on the server. (Either through a StringConstant or a PropertyTag on the category, most likely)
Comment 4 Lee Newson 2013-06-06 21:31:18 EDT
Closing and setting as current release as no QA was performed by the original reporter. If there is still an issue with this bug still than please re-open it.

Note You need to log in before you can comment on or make changes to this bug.