Bug 806622 - [abrt] telnet-0.17-51.fc16: __GI_raise: Process /usr/bin/telnet was killed by signal 6 (SIGABRT)
[abrt] telnet-0.17-51.fc16: __GI_raise: Process /usr/bin/telnet was killed by...
Status: CLOSED DUPLICATE of bug 739743
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Law
Fedora Extras Quality Assurance
abrt_hash:1509189983371a95d2a7beecbbd...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-25 09:21 EDT by Suren Karapetyan
Modified: 2016-11-24 10:53 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-23 14:33:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (15.20 KB, text/plain)
2012-03-25 09:21 EDT, Suren Karapetyan
no flags Details
File: maps (4.76 KB, text/plain)
2012-03-25 09:21 EDT, Suren Karapetyan
no flags Details

  None (edit)
Description Suren Karapetyan 2012-03-25 09:21:48 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        telnet 80.86.227.147 25
crash_function: __GI_raise
executable:     /usr/bin/telnet
kernel:         3.3.0-4.fc16.x86_64
pid:            24745
pwd:            /home/suro
reason:         Process /usr/bin/telnet was killed by signal 6 (SIGABRT)
time:           Sun 25 Mar 2012 05:16:42 PM AMT
uid:            1000
username:       suro
var_log_messages: Mar 25 17:16:42 pacho abrt[24746]: Saved core dump of pid 24745 (/usr/bin/telnet) to /var/spool/abrt/ccpp-2012-03-25-17:16:42-24745 (561152 bytes)

backtrace:      Text file, 15568 bytes
maps:           Text file, 4878 bytes

build_ids:
:7e38d4068ce4d86cb3f22c2676cbe7f8bdccc15d
:638db099ff5fb986d1a092629d1bb1dca5be4904
:e5429e0905bedecc534b057783916ba43e06a66e
:dacf32a9a2f2b5077ba944e7b835cca6f637f78f
:b2addb78b534f66e1c4fb01a407861181151bd8a
:e2e67b3ae2579e1667b73ad385f61552931024e9
:aa733447f84020c94a66814e501a36e248cbb43d
:c8e7f118041a9f77e0dd673da11b5653be27b5a2
:36fc045d11fc55f1b455247938e651666e2c127e
:3cbc639da8b05f5cd87202ff77c5c335313d3276
:1a212c7f1515542b310ba92f6109efc9b5bf2b6e
:124ea19b54427baeb1a112816de9aa39eb2d7c17

dso_list:
:/lib64/libdl-2.14.90.so glibc-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1105718508
:/lib64/libnss_dns-2.14.90.so glibc-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1105718508
:/lib64/libtinfo.so.5.9 ncurses-libs-5.9-2.20110716.fc16.x86_64 (Fedora Project) 1105718513
:/lib64/libnss_files-2.14.90.so glibc-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1105718508
:/lib64/libnss_mdns4_minimal.so.2 nss-mdns-0.10-9.fc15.x86_64 (Fedora Project) 1331735823
:/lib64/libutil-2.14.90.so glibc-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1105718508
:/usr/bin/telnet telnet-1:0.17-51.fc16.x86_64 (Fedora Project) 1105720256
:/lib64/libc-2.14.90.so glibc-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1105718508
:/lib64/libresolv-2.14.90.so glibc-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1105718508
:/lib64/libncurses.so.5.9 ncurses-libs-5.9-2.20110716.fc16.x86_64 (Fedora Project) 1105718513
:/lib64/ld-2.14.90.so glibc-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1105718508
:/lib64/libnss_myhostname.so.2 nss-myhostname-0.3-1.fc16.x86_64 (Fedora Project) 1105719236

environ:
:XDG_VTNR=1
:SSH_AGENT_PID=16459
:XDG_SESSION_ID=20
:KDE_MULTIHEAD=false
:HOSTNAME=pacho
:DM_CONTROL=/var/run/xdmctl
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=xterm
:XDG_MENU_PREFIX=kde4-
:XDG_SESSION_COOKIE=88eee7aa21159a1cd4dd574300000009-1332491261.82556-404098873
:HISTSIZE=1000
:XDM_MANAGED=method=classic
:GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/suro/.gtkrc-2.0:/home/suro/.gtkrc-2.0-kde4:/home/suro/.kde/share/config/gtkrc-2.0
:KONSOLE_DBUS_SERVICE=:1.47
:GS_LIB=
:GTK_RC_FILES=/etc/gtk/gtkrc:/home/suro/.gtkrc:/home/suro/.kde/share/config/gtkrc
:WINDOWID=52428827
:QTDIR=/usr/lib64/qt-3.3
:SHELL_SESSION_ID=1fed7f526167400082cc44c24bed1a2a
:QTINC=/usr/lib64/qt-3.3/include
:KDE_FULL_SESSION=true
:IMSETTINGS_MODULE=none
:USER=suro
:LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:*.pdf=00;33:*.ps=00;33:*.ps.gz=00;33:*.txt=00;33:*.patch=00;33:*.diff=00;33:*.log=00;33:*.tex=00;33:*.xls=00;33:*.xlsx=00;33:*.ppt=00;33:*.pptx=00;33:*.rtf=00;33:*.doc=00;33:*.docx=00;33:*.odt=00;33:*.ods=00;33:*.odp=00;33:*.xml=00;33:*.epub=00;33:*.abw=00;33:*.html=00;33:*.wpd=00;33:
:SSH_AUTH_SOCK=/tmp/ssh-JJvpLGD16305/agent.16305
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/16516,unix/unix:/tmp/.ICE-unix/16516
:DESKTOP_SESSION=default
:MAIL=/var/spool/mail/suro
:PATH=/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/local/sbin:/usr/sbin:/sbin:/home/suro/.local/bin:/home/suro/bin
:QT_IM_MODULE=xim
:PWD=/home/suro
:XMODIFIERS=@im=none
:KDE_SESSION_UID=1000
:LANG=en_US.UTF-8
:KDE_IS_PRELINKED=1
:KDEDIRS=/usr
:KONSOLE_DBUS_SESSION=/Sessions/10
:HISTCONTROL=ignoredups
:SSH_ASKPASS=/usr/bin/ksshaskpass
:HOME=/home/suro
:COLORFGBG=15;0
:XDG_SEAT=seat0
:SHLVL=3
:KDE_SESSION_VERSION=4
:LANGUAGE=
:XCURSOR_THEME=default
:LOGNAME=suro
:QTLIB=/usr/lib64/qt-3.3/lib
:XDG_DATA_DIRS=/usr/share/kde-settings/kde-profile/default/share:/usr/local/share:/usr/share
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-C8MFZcAmdw,guid=ba50616be0026b56f4d833340000ecc3
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:PROFILEHOME=
:XDG_RUNTIME_DIR=/run/user/suro
:DISPLAY=:0
:QT_PLUGIN_PATH=/home/suro/.kde/lib64/kde4/plugins/:/usr/lib64/kde4/plugins/:/usr/lib/kde4/plugins
:GTK_IM_MODULE=gtk-im-context-simple
:XAUTHORITY=/tmp/kde-suro/xauth-1000-_0
:_=/usr/bin/telnet

smolt_data:
:
:
:General
:=================================
:UUID: 8969777c-aa7e-4b01-a19a-bccb001bcfc9
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 5586.95
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i5-2300 CPU @ 2.80GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 4
:CPU Speed: 2801
:System Memory: 7969
:System Swap: 9951
:Vendor: System manufacturer
:System: System Product Name System Version
:Form factor: Desktop
:Kernel: 3.3.0-4.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:7260:4163:33869) pci, None, PCI/ISA, H61 Express Chipset Family LPC Controller
:(6945:4224:4163:33929) pci, None, PCI/PCI, N/A
:(32902:9294:4163:33869) pci, None, PCI/PCI, 82801 PCI Bridge
:(32902:7190:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(4318:2595:0:0) pci, nouveau, VIDEO, GT218 [GeForce 210]
:(32902:7192:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 5
:(32902:7200:4163:33813) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(4332:33128:4163:33842) pci, r8169, ETHERNET, P8P67 Deluxe Motherboard [Realtek RTL8111E]
:(32902:7202:4163:33869) pci, i801_smbus, SERIAL, P8P67 Deluxe Motherboard
:(32902:7170:4163:33869) pci, ahci, STORAGE, P8P67 Deluxe Motherboard
:(32902:7213:4163:33869) pci, ehci_hcd, USB, P8P67 Deluxe Motherboard
:(32902:7206:4163:33869) pci, ehci_hcd, USB, P8P67 Deluxe Motherboard
:(32902:256:4163:33869) pci, None, HOST/PCI, P8P67 Deluxe Motherboard
:(32902:7226:4163:33869) pci, None, SIMPLE, P8P67 Deluxe Motherboard
:(4318:3042:0:0) pci, snd_hda_intel, MULTIMEDIA, High Definition Audio Controller
:(32902:7194:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 6
:(32902:257:4163:33869) pci, pcieport, PCI/PCI, Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_pacho-lv_root / ext4 4096 4096 13081819 8421202 7765842 3276800 3075255 3075255
:/dev/sda2 /boot ext4 1024 1024 508745 410811 385211 128016 127786 127786
:/dev/mapper/vg_pacho-lv_home /home ext4 4096 4096 25561025 24682664 23402664 6406144 6391554 6391554
:
Comment 1 Suren Karapetyan 2012-03-25 09:21:55 EDT
Created attachment 572528 [details]
File: backtrace
Comment 2 Suren Karapetyan 2012-03-25 09:21:57 EDT
Created attachment 572529 [details]
File: maps
Comment 3 Adam Tkac 2012-05-22 04:26:33 EDT
After further inspection this looks like glibc issue.

Backtrace says that telnet's env_init() function calls getaddrinfo with valid parameters. Parameters are:

node: "pacho\000\000\000\210B\335\024\064\177"
service: NULL
hints: zero-ed, except the ai_flags field
hints.ai_flags: AI_V4MAPPED | AI_ADDRCONFIG | AI_CANONNAME
res: valid pointer

Reassigning to glibc.
Comment 4 Jeff Law 2012-05-23 14:33:19 EDT

*** This bug has been marked as a duplicate of bug 739743 ***

Note You need to log in before you can comment on or make changes to this bug.