Bug 806750 - [c1f8af00eaa03f1c2a7ea145ff627ca749e330cb]: fileop fails when quota is enabled & replace-brick is going on
[c1f8af00eaa03f1c2a7ea145ff627ca749e330cb]: fileop fails when quota is enable...
Status: CLOSED WORKSFORME
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
pre-release
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Raghavendra G
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 03:14 EDT by Rahul C S
Modified: 2015-12-01 11:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-09 04:11:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul C S 2012-03-26 03:14:27 EDT
Description of problem:
root@Dagobah:/data/mounts/mount# /opt/qa/tools/fileop -f 30 -t 

Fileop:  Working in ., File size is 1,  Output is in Ops/sec. (A=Avg, B=Best, W=Worst)
Mkdir failed

fileop failed because, when replace-brick is happening, the quota thinks that the limit has been exceeded as it says in the log file.

client log where fileop failed:
[2012-03-26 12:35:38.027440] W [client3_1-fops.c:1589:client3_1_entrylk_cbk] 0-vol-client-3: remote operation failed: No such file or directory
[2012-03-26 12:35:38.031252] W [client3_1-fops.c:1589:client3_1_entrylk_cbk] 0-vol-client-3: remote operation failed: No such file or directory
[2012-03-26 12:35:38.035945] W [client3_1-fops.c:1489:client3_1_inodelk_cbk] 0-vol-client-3: remote operation failed: No such file or directory
[2012-03-26 12:35:38.039417] W [client3_1-fops.c:1489:client3_1_inodelk_cbk] 0-vol-client-3: remote operation failed: No such file or directory
[2012-03-26 12:36:17.572514] W [fuse-bridge.c:272:fuse_entry_cbk] 0-glusterfs-fuse: 8807: MKDIR() /fileop_L1_3/fileop_L1_3_L2_3/fileop_dir_3_3_18 => -1 (Disk quota exceeded)

Both the clients are connected to the same volume, & the volume is a 2x2 distributed-replicate volume.

df -h output:
dagobah:vol           7.0G  262M  6.8G   4% /data/mounts/fuse
dagobah:vol           7.0G  -75G   82G   -  /data/mounts/mount
Comment 1 Raghavendra G 2012-04-09 04:11:45 EDT
Without setting any limits on directories, this issue is not seen. When set, if there are any issues, this seems to be a duplicate of bug #773530. Hence closing this bug

Note You need to log in before you can comment on or make changes to this bug.